I am trying to create an 11.10 VirtualBox client using the same DVD I used to upgrade my host system. (It happens to be the alternate DVD ISO.)

However, it keeps hanging when the progress bar reaches about 70%. The last command above the progress bar is log-output -t ubiquity laptop-detect but this appeared much earlier in the process (the progress bar keeps going and only hangs later).

By searching for symptoms I eventually found out what my specific problem was (see below), but I still don't know how to find an error message while I'm busy installing on a fresh VirtualBox.

Are there logs I can access, a command-line mode I can switch to, or some other means of finding a report of what is going wrong, assuming there is one?

(If it is not possible to do so, please provide some kind of authoritative reference confirming this.)

  • funny ... I just got this today, ended up porting to vmware – Sam Saffron Nov 9 '11 at 11:46
  • I've found a solution but not an answer on how to debug installer issues, so the bounty is still available :) – david.libremone Nov 14 '11 at 10:36
  • ... maybe its just me ... but if you still want help, dont accept your own answer - at least, not until the bounty period has finished. It looks very much like, the question has been resolved by your good-self. – fossfreedom Nov 16 '11 at 12:08
  • @fossfreedom fair enough :) – david.libremone Nov 16 '11 at 12:19

I tried the following without resolving the problem, but they may be useful to know:

  • increasing client HDD space to 9GB (it actually won't install without this)
  • increasing client memory to 1GB (apparently there may be problems with only 512MB)
  • disabling client network adapter to stop the installer trying to make network connections

In my case, I needed to change my client storage options, which solved the problem with hanging:

Option 1: ext3

Ubuntu 11.10 creates an ext4 partition by default. This debian-installer bug gave me a hint to try an ext3 partition instead. When I did this, the installation completed successfully.

Option 2 (preferred): Enable host I/O cache

However, I think a better solution is to create a new client machine and then tick "Enable host I/O cache" on the SATA controller of the client machine (find it under Storage on the client machine settings). [1] [2] When I did this, I could successfully install Ubuntu using the default (ext4) partition options, which I prefer for no other reason than that it is the default.

Other candidates

If this didn't help you try:

How to debug? I don't know.

I posted here on AU, the VirtualBox forums, and solved it by searching for my specific symptoms. I still don't know how to retrieve error messages from the installer itself.

| improve this answer | |
  • Remember to mark this question as answered :) – RolandiXor Nov 16 '11 at 13:35
  • @RolandTaylor after some deliberation I'm not going to :D I've clarified what I'm actually looking for (how to debug, rather than the solution to the specific problem I had) – david.libremone Nov 21 '11 at 6:36

In my case it was a trouble with physical memory of host machine. I've run memtest on host machine and it passed OK. Then I have run it in VirtualBox and it ended in errors after an hour. Having replaced the suspicious memory bank, I repeated the test overnight to see no problems. Before replacement, I could not install Mint.

| improve this answer | |
  • did you run memtest before or after installation? if before, can you detail how? thanks! – david.libremone Nov 16 '11 at 12:59
  • Just took a liveCD image with that function. Knoppix, may be, or Panacea. – Barafu Albino Nov 16 '11 at 13:04
  • just confirmed there is a memory test option on the ubuntu alternate ISO as well (I'm guessing there's one on the normal ISO too) – david.libremone Nov 19 '11 at 11:13

My installation required the selection of the third party software to enable the wireless adaptor. Should have read the banners more carefully.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.