i just came from Windows 10 to ubuntu 16.04 and can't find solution or any fix for my problem. I'm using dual monitors (both the same models-Samsung S22D300N).Monitor(1) is connected via VGA-VGA cable, Monitor(2) is connected by VGA-VGA-to-DVI adapter.

On monitor(2) my ressolution can't pass 1360x768 while monitor(1) is running on 1920x1080.Everything is working okey on Win10, both monitors on 1920x1080.

I have installed lastest nvidia drivers but resolution problems is still there. I'll do my best do provide all the necessery information.

GPU-Geforce GTS450

xrandr 

> Screen 0: minimum 8 x 8, current 3280 x 1080, maximum 16384 x 16384
DVI-I-0 connected 1360x768+1920+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768      60.00 +
   1360x768      59.96*   59.80  
   1152x864      60.00  
   800x600       72.19    60.32    56.25  
   680x384       59.96    59.80  
   640x480       59.94  
   512x384       60.00  
   400x300       72.19  
   320x240       60.05  
VGA-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080     60.00*+
   1680x1050     59.95  
   1600x900      60.00  
   1440x900      59.89  
   1280x1024     75.02    60.02  
   1280x800      59.81  
   1280x720      60.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   640x480       75.00    72.81    59.94  
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
  1600x900_60.00 (0x3b6) 118.250MHz -HSync +VSync
        h: width  1600 start 1696 end 1856 total 2112 skew    0 clock  55.99KHz
        v: height  900 start  903 end  908 total  934           clock  59.95Hz
  1920x1080_60.00 (0x3b8)  9.250MHz -HSync +VSync
        h: width  1920 start 1976 end 2160 total 2400 skew    0 clock   3.85KHz
        v: height   60 start   63 end   73 total   76           clock  50.71Hz<
  • try using nvidia x server settings – Frank Schrijver May 18 '16 at 17:57
  • I tried, it didn't let me use anything past 1360x768. – Scqueen Walker May 18 '16 at 19:15

First save any work in case your screen turns off and won't turn on without restarting. What I am going to suggest is temporary to begin with; you can make it permanent if it works.

Go to the terminal and run cvt 1920 1080 60.

This will output a string of text or two. The last one should start with the word Modeline. Copy from the first text after Modeline which should be "1920x1080_60.00" [...] to the end of the line (should end with [...] +vsync.

Then type in xrandr --newmode and paste what you copied.

Then type in xrandr --addmode DVI-I-1 "1920x1080_60.00"

Then type in xrandr --output DVI-I-1 --mode "1920x1080_60.00".

To make it permanent:

If this works, create or edit the file ~/.xprofile and add the last three commands that you typed in into it.

  • "xrandr --addmode DVI-I-0 "1920x1080_60.00" X Error of failed request: BadMatch (invalid parameter attributes) Major opcode of failed request: 140 (RANDR) Minor opcode of failed request: 18 (RRAddOutputMode) Serial number of failed request: 31 Current serial number in output stream: 32 " – Scqueen Walker May 18 '16 at 19:16

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.