0

I'm trying to set up my ownCloud for my school but there is just 1 problem

PHP module GD not installed.

Please ask your server administrator to install the module.
PHP modules have been installed, but they are still listed as missing?

Please ask your server administrator to restart the web server.

I have installed php5-gd like 4 times from different sources, restarted Apache every time, I have even reinstalled Ubuntu server in my machine (cause of the mess of installing and reinstalling stuff)

I'm new on this. I started Ubuntu like 1 month ago (love it) and trying to set up the server for 1 week ago actually.

I have to say I'm really annoyed cause of the php-gd cause I have fixed every "problem" I have gotten during the installation of other stuff but PHP gd beat me. All solutions I have found are related to installation, but I have the impression that maybe I'm missing something in Apache2. I don't feel like not installing ownCloud or change OS just cause ownCloud tells me "PHP module GD not installed."

I'm working on Ubuntu server 14.04 following this tutorial How To install own cloud also tried with the ownCloud install instructions of the own cloud page, but have to say this:

All downloads OK

All updates OK

Repository stuff No Errors all OK

Tried with PHP 5 and PHP 7 modules

Used Ubuntu server 16 before learning that 14.04 was better ( ironic)

Apache running with no problems (access via XXX.XXX.X.X and I get Apache2 Ubuntu Default Page)

I have access to ownCloud ( on xxx.xxx.x.x/owncloud) just see the errors


Please update your question with the version of owncloud you're trying, and also the error that's output from owncloud

I have tried with the ownCloud 7,8, and 9.0.2 (which is the actual stable version).
The only error I get is this screen: ownCloud - GD module missing screeshot

  • Please update your question with the version of owncloud you're trying, and also the error that's output from owncloud. – user508889 May 18 '16 at 16:57
  • After installing the module, it may not be getting enabled. Try sudo php5enmod gd after installing it with apt-get install php5-gd. Don't forget to restart apache enabling the module. – Dan May 18 '16 at 17:32
  • THANKS Dan thats was the fix, now not willing to be annoying but wut did i just did with " en mod ? By the way problem is fixed im new so i don't know how to close the thread and giving points – Yoa Oses May 18 '16 at 18:54
0

Installing the php5-gd module with apt-get install php5-gd does not enable the module directly. In order to enable it, you should use the following command before restarting apache.

sudo php5enmod gd
sudo apache2ctl restart

php5enmod stands for PHP5 Enable module. This the same command you can use for enabling Apache2 modules (a2enmod), but for PHP5 modules.
To disable modules you would use php5dismod.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.