11

Dead keys for accents (like â, è, ç) stopped working in LibreOffice and Pidgin after I upgraded to Ubuntu 16.04.

  • Instead of editing the answer into your text, it would be better to click the check mark on the answer that solved your problem. – rotaredom Jan 12 '18 at 13:30
8

To fix, I used ibus-setup in a terminal and followed instructions. It went back to normal.

  • 1
    Hi, @dsimard, and thanks for sharing. However, it sounds as a bug to me, and it would be great if you could provide more details, so it possibly can be fixed for everyone. (It should be said that there is normally no need to start ibus-setup on Ubuntu nowadays. Whatever you did - not clear to me - sounds like a workaround.) – Gunnar Hjalmarsson May 18 '16 at 16:46
  • I can give more details but I guess that situation is very exceptional. - I upgraded from 14.10 - I remember having the same problem when I upgraded to 14.10 two years ago. There was an option somewhere about ibus and I clicked it (don't remember if I checked or unchecked the box) - I recently upgraded to 16.04 with a keyboard setting at French (Canada) by default - The accents with dead keys (example : typing ` and then e to have è) stopped working in Pidgin and LibreOffice. Everything else I tried was fine. I'm not sure which details you would need. Let me know if it helps – dsimard May 18 '16 at 18:50
  • I switched to French (Canada) on my 16.04, and the dead keys worked as expected in LibreOffice directly, so I couldn't reproduce the problem. It may be due to some leftover in your $HOME (please note that 14.10 has been unsupported for quite some time, and there is no official upgrade path from 14.10 to 16.04 - might also be related). – Gunnar Hjalmarsson May 18 '16 at 19:33
  • I have the same problem with my spanish keyboards. upgraded from 15.10 to 16.04 – Luis Masuelli Jul 3 '16 at 21:47
  • The fix works but... I have to do that everytime I boot. How can I fix it once for good? – Luis Masuelli Jul 3 '16 at 21:49
3

This issue is better solved by the next input:


$ ibus-daemon --xim


And, also activating this Keyboard input method system in the System preferences - Language Support:

Keyboard input method system => XIM

The reason is that, when a language has complex characters like "à", the "Ibus" always generates problems, even to the "very known" non Gnome applications like Skype and Microsoft Office-PlayOnLinux. The typical error is that appears "`a" instead of "à".

My recommendation is that you add the "ibus-daemon --xim" as Startup Application in order to forget this issue forever.

  • Thanks. The ibus suggestions hasn't worked for me so tried this now, will see next time I restart X if it helped or not. :) – Per Lundberg Nov 21 at 9:54
1

I got this problem after updating my Debian testing system with XFCE desktop. I solved it this way:

  1. Click on XFCE -> Settings -> IBus Preferences
  2. Click 'yes' on the dialog whether you want to start the IBus daemon
1

The fix provided by ibus-setup may not work after startup. To start it with the session, add to startup the command ibus-daemon --xim, as stated here.


UPDATE ON A DIFFERENT CAUSE THAN iBUS:

In Kubuntu 18.04 all worked fine. Trying LXQt on top of that and no dead keys in Libreoffice. It seems in this case it was not an ibus problem, but one with the libreoffice UI backend - as suggested here. Solved it as indicated here: edit/create the file /etc/profile.d/libreoffice-fresh.sh ( or /etc/profile.d/libreoffice-still.sh, as said here) and uncomment/add the line export SAL_USE_VCLPLUGIN=gtk3, then reboot.

0

I recently changed the flavor from Unity to Mate and faced the same problem. I found a solution, hope it helps.

central panel -> ibus preferences -> advanced

unmark keyboard layout & global input method settings.

enter image description here

  • Didn't work for me. Do you need to restart anything after making this change? (Using Debian buster/bullseye for the record) – Per Lundberg Nov 21 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.