1

Three days I'm striggling with this problem. lsusb isn't detecting my ASUS Fonepad 7, but detects my Lumia, which is a Windows Phone device. I tried plugging my sister's phone, my dad's phone, which are both android marshmallow devices, but no android is ever detected. Every solution I find in the Internet is based on the 51-android.rules file or enabling MTP on the device itself. This, however is still not working on my machine. I have the .rules file and MTP is enabled on my ASUS Fonepad 7. Yet, when I run lsusb, no android device is detected, which also affects adb devices's results. Any help is appreciated!

EDIT: I'm using ElementaryOS Freya, based on Ubuntu 14.04 LTS.

0

You can try setting USB debugging to enabled in the developer options. You should be able to run lsusb then.

0

Had the same problem - the cable didn't support data transfer. Try changing the cable that you use to connect the device to.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.