0

I am new to Ubuntu and so far not having a very pleasant user experience. I have tried to install multiple programs but no luck. The software "app" does not work and I get an error of Failed to load the package list, followed by details:

E:Malformed entry 54 in list file /etc/apt/sources.list (Suite),  
E:The list of sources could not be read.

I have tried appending repositories in the apt list file but that is not working. I am at my wits end.
Please help.

1

1- First of all run sudo apt-get update and check if the problems persists

2- Maybe the repository is disabled.

You can enable it in the grafical way, going to settings and then ubuntu software You will see something like this

enter image description here check them.

You can also enable then in command line. Press ctrl + alt + t and: sudo add-apt-repository "deb http://archive.ubuntu.com/ubuntu $(lsb_release -sc) main universe restricted multiverse"

Source: How do I enable the "Universe" repository? https://help.ubuntu.com/community/Repositories/Ubuntu

0

Let's try to clear up the 'partial' error first. Be very careful with these commands:

sudo rm -vf /var/lib/apt/lists/partial/* # Remove files in 'partial'
sudo rm -vf /var/lib/apt/lists/* # Remove package lists in 'lists'
sudo apt-get update

If you are still getting a 'status' error, try restoring a backup copy of the file:

sudo mv /var/lib/dpkg/status /var/lib/dpkg/status.0715
sudo cp /var/backups/dpkg.status.0 /var/lib/dpkg/status
sudo apt-get update

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.