13

Up to version 4.3, one could use the spadmin tool to setup a fax driver – which worked perfectly for me in OpenOffice and later LibreOffice. Having updated to version 5.x, that fax driver stopped working – and the spadmin tool had disappeared from LibreOffice.1 Simply copying the psprint.conf file to the new location didn't help (as the linked post1 indicates).

As a work-around I currently have to print my faxes and then scan them to the fax printer – which obviously defeats the purpose of a "paperless office".

Is there any (not too difficult) way to restore the direct "print-to-fax" functionality in LibreOffice?

PS: I have a Brother MFC 9120 CN here, the corresponding drivers (LPD, CUPS, FAX) are installed on my Ubuntu 12.04 machine. And before you ask: No discussion please about upgrading to 14.04/16.04, that's not part of this question :)


1: see e.g. spadmin gone from libreoffice

  • 1
    Are you using HylaFAX? Does your fax show up as a fax machine or only a printer? spadmin was removed from LibreOffice because the distros now manage the faxes themselves. – Dorian May 26 '16 at 16:43
  • @XToro My Fax appears as printer (but chosing that in LO doesn't work: no prompt for the fax number, so no fax sending possible). And no, I'm not using HylaFAX (or any software based solution), that'd be overkill for the few faxes I have to send. If distros "now manage the faxes themselves", it might be helpful pointing out how that's done (and how to do it on Ubuntu). – Izzy May 26 '16 at 16:51
  • have you tried link ? Or this answer might help – Dorian May 26 '16 at 17:33
  • 1
    After looking around a while and reading some old bug reports, it seems that faxing isn't getting any attention since so few people use it. Everyone is moving over to e-mail and even efaxing services. Looks like you may have to migrate to something different. For the record, my Canon MFP can fax and works right away when plugged in using 16.04. So you have 3 options it seems: You'll have to upgrade either Ubuntu, send documents a different way, or, downgrade LibreOffice back to what worked. – Dorian May 26 '16 at 19:19
  • 1
    No problem, it was a solution looking for a problem. :-) just not the right problem. I am with the other guys though, I have an HP all in one laser printer, and when I install the HP cups drivers I download from HP, I get a fax printer, and when I print to that, I get all the dialogues about number, and cover sheet, who I am sending it to etc. If you aren't getting that then I think that is the real problem not LO. – Christopher Angulo-Bertram May 27 '16 at 21:56
3

On further investigation, several hints led me to a proposed solution1: Brother provides a fax modem driver (brfaxmodem-1.1.3-1.i386.deb) which you can download from their support site (link is for MFC9120CN). Their instructions then say:

  1. have your printer connected via USB
  2. install the driver: sudo dpkg -i brfaxmodem-1.1.3-1.i386.deb2
  3. install the efax package: sudo apt-get install efax
  4. open /etc/efax.rc using a text editor and change "DEV=ttyS1" into "DEV=modem"

Now you should be able adding a new printer: "AppSocket/HP JetDirect" with Hostname: localhost, Port: 9900, printer typ: Generic -> Raw Queue. Having that done, check that /etc/cups/printers.conf contains socket://localhost:9900. efax doesn't start automatically, so you'll have to do that manually when you need it (or create yourself a startup script to have Ubuntu taking care for that at boot).

If LibreOffice/OpenOffice doesn't detect this "fax printer" (which according to the change logs it should), Fax4CUPS might be needed:

… So the current LibreOffice version in Ubuntu 14.04 LTS is obsolete. I've updated my LO to 5.0.1.2 and the fax integration has changed. spadmin no longer exists, and an external script, fax4CUPS is required.

Fax4CUPS is a CUPS backend for efax/hylafax/mgetty-fax. At the URL given you can find a .deb package you again need to install via sudo dpkg -i fax4cups_2.0-1_all.deb. Further instructions then can be found in its man page: man fax4CUPS.


1not yet tested by me due to lack of time – but I don't want to a) lose the notes and b) keep them away from you. I will accept this answer once I've tested it successfully.
2on a 64bit installation, you'll obviously need the 32bit support for that, unfortunately

0

To send a fax directly from LibreOffice, you need a fax modem and a fax driver that allows applications to communicate with the fax modem.

Sending a Fax Through the Print Dialog

  1. Open the Print dialog by choosing File - Print and select the fax driver in the Name list box.
  2. Clicking OK opens the dialog for your fax driver, where you can select the fax recipient.

Configuring LibreOffice a Fax Icon

You can configure LibreOffice so that a single click on an icon automatically sends the current document as a fax:

  1. Choose Tools - Options - LibreOffice Writer - Print.
  2. Select the fax driver from the Fax list box and click OK.
  3. Click the arrow icon at the end of the Standard bar. In the drop-down menu, choose Customize. The Toolbars tab page of the Customize dialog appears.
  4. Click Add Commands.
  5. Select the "Documents" category, then select the "Send Default Fax" command.
  6. Click Add and then Close.
  7. On the Toolbars tab page, click the down arrow button to position the new icon where you want it. Click OK. Your Standard bar now has a new icon to send the current document as a fax.

(Source: LO help page Sending Faxes and Configuring LibreOffice for Faxing)

Sincerely,

Karsten

  • Thanks for trying, Karsten. But no need to copy-paste the LO help page without mentioning the source, I've of course read that. Maybe I was not explicit enough, but as my question states I wanted to restore the print-to-fax functionality I had before, with my MFC device – not buying some hardware to achieve that (fax modem). – Izzy Jun 14 '16 at 5:49
  • Saddly this answer (and others) only works with "Fax Modems" and the "Fax Printers" seem to be under supported at the moment. – Jason Jan 23 '17 at 19:13
0

Time to update, as I didn't use my other proposed solution:

I ended up with a completely different solution, which I also want to share here after using it now for almost 2 years. My Brother MFC isn't involved in it at all.

As I'm using a Fritz!Box to connect my home to the Internet and telephony network, which has fax capabilities integrated, I've set that up there and then used Roger Router – which, among other things, provides a fax interface LibreOffice/OpenOffice can interact with directly. Setup of Roger Router is pretty easy and straight-forward, with each step explained, and your Fritz!Box even detected automatically.

Assistant Fax Settings
The Assistant starting up // Fax Settings (source: Ubuntu Wiki)

As a side-effect I get a bunch of nice-to-have functionality such as a local protocol (from which one can listen to recorded calls or view incoming/outgoing faxes) and desktop notifications of incoming/outgoing calls. I even can manage my Fritz!Box address book via Roger Router.

Roger Router is available via a PPA:¹

sudo sh -c "echo 'deb http://download.opensuse.org/repositories/home:/tabos-team:/release/xUbuntu_16.04/ /' > /etc/apt/sources.list.d/roger.list"
wget -q http://download.opensuse.org/repositories/home:/tabos-team:/release/xUbuntu_16.04/Release.key -O- | sudo apt-key add -
sudo apt-get install roger

Make sure to adjust the first line according to the Ubuntu version you're using. My example has the latest LTS (16.04). For other available versions (and distributions), please see here (in short, and for this site's topic: 14.04, 16.04, 17.04 and 17.10 are available as of this writing).

Once Roger Router was installed and configured, just select it as default fax in LibreOffice/OpenOffice as described in Karsten's answer.


¹ it seems the PPA will no longer be updated, though, as the developer has switched to FlatPak; if you can read German, see here.

0

Izzy wrote a brilliant text. This helped me a lot. It made it work for me the very first time. Great!

Since I use a different setup (Ubuntu 17.10, V.90 - Modem, XFCE4) I want to share my results:

**

- ** How To send a FAX with Libre Office, Ubuntu 17.10, XFCE4 **

**

Send faxes directly from within LibreOffice.

** FAXe direkt aus Libre Office versenden mit Ubuntu 18.10, XFCE4 und unter anderen Versionen (diese Anleitung funktioniert und wird regelmaessig aktualisiert!)

**

**

0) You have a modem installed (external via serial is most easy)

To find out if the modem is connected you may try

sudo dmesg | grep tty

and look for an answer like

[2.301047]: ttyS0 at I/O 0x3f8 (irq = 4, base_baud = 115200) is a 16550A

So here we see it actually is "ttyS0"

Tip: COM1 = ttyS0 (most Modems are connected to ttyS0; modern boards only have one COM1, you can buy the connector from delock if not provided)

1) Install efax-gtk

efax-gtk comes with comprehensive help: F1 !

2) Open efax-gtk GUI from menue

3) Configure Settings.

Params: use default (init is: Z &FE&D2S7=120 &C0 M1L0)
Socket: Run server, defaults
Logging: A name allowed or a user - writable path 
Page: choose A4

Setup OS

4) Add printer:

New Printer

choose Enter URI, paste this:

socket://localhost:9900

Forward „Generic"

Forward „Raw Queue“

Forward choose name

and finalise.

Check settings in /etc/cups/printers.conf

it should say something like

<Printer SockPrint>
UUID urn:uuid:9z8z3dbe-68b1-3891-5136-96f1cc4b3210
Info socket4FAX-print
Location 
DeviceURI socket://localhost:9900
State Idle
StateTime 1519995207
ConfigTime 1519996041
Type 4
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy retry-job
</Printer>

Does not do anything(??): /etc/efax-gtkrc

/etc/efax.rc

looks like this example:

# for any explanation look into /usr/bin/fax (!)

# what device is used? COM2 means ttyS1 DEV=ttyS0

FROM=" +49 3222 1111111"

NAME=" from Firstname Lastname "

SPKR="-iM2L3"

PAGE=a4

PAGE_a4="210x295mm"

efax-gtk

writes configs here:

$HOME/.efax-gtkrc, $sysconfdir/efax-gtkrc or /etc/efax-gtkrc (starts with home!)

5a) Start efax-gtk .

5b) Start LibreOffice .

a) Print to the new socket printer

b) Go to efax-gtk GUI, choose

Fax entry method: Socket

Klick „Socket list“

Rest should be obvious ;-) Otherwise troubleshoot....

Nachtrag:

Damit die Faxfunktion systemseitig nach jedem reboot zur Verfügung gestellt wird, sollte man efax-gtk automatisch starten lassen.

Eine probate Methode ist der Eintrag efax-gtk -s im GUI Menue "Session and startup" (wie auch immer das in Deutsch übersetzt wird).

  • FAX senden mit Libre Office, Ubuntu 18.04, xfce4: Aus Erfahrung kann ich bestaetigen, dass es genau so funktioniert. Die efax-gtk GUI ist im Menue, da kann man sie anklicken. Der Rest ist wie gehabt: Start LibreOffice. 1) Print to the new socket printer 2) Go to efax-gtk GUI, choose Fax entry method: Socket Klick „Socket list“ Rest should be obvious ;-) – opinion_no9 Jun 17 '18 at 10:49
  • Die oben beschriebene Loesung "... send a FAX with Libre Office ... " funktioniert definitiv mit Ubuntu 18.10 in dieser Form. – opinion_no9 Jul 16 '18 at 21:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.