5

When attempting to start the Terminal application from Unity Dash, the icon appears, flashes for several seconds, and then disappears. When attempting to start gnome-terminal from xterm, I receive the following output (line breaks added after colons for easier reading):

 Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0:
 Error calling StartServiceByName for org.gnome.Terminal:
 GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited:
 Process org.gnome.Terminal exited with status 127

A cursory search of the issue lead to several suggestions concerning issues with the locale settings, but my locale appears fine:

richard@lappy-x64:~$ cat /etc/default/locale
LANG=en_US.UTF-8
richard@lappy-x64:~$ echo $LANG
en_US.UTF-8
richard@lappy-x64:~$ echo $LANGUAGE
en_US

Any ideas for additional troubleshooting?

  • 1
    Haven't solved the problem (Running Windows 10/Vagrant/VirtualBox/box-cutter/ubuntu1604-desktop) but did find a way to launch Terminal: use dbus-launch. bbs.archlinux.org/viewtopic.php?pid=1585415#p1585415 – Kenneth Brubaker Jan 7 '17 at 14:10
  • @KennethBrubaker This solved my problem immediately. I am using Cygwin/X and formerly PuTTY to ssh to a Ubuntu 16.04. I can run xterm and gedit successfully, so it looks like it's the gnome-terminal has some problem. – Yvon Jun 28 '17 at 21:59
  • Look at this thread to see if purging locale works: ubuntuforums.org/showthread.php?t=2295530! – George Udosen Nov 27 '17 at 10:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.