0

I have a brother hl1112 printer and it suddenly stopped working after an update (I don't know which one exactly, I automatically dist-upgrade daily).

I am running 14.04 amd64 with kernel version 3.13.0-86. I tried with version -85, the latest wily kernel, and reinstalling the driver (http://support.brother.com/g/b/downl...ng=4&type3=625) but it still does not work.

More precisely I can print test pages from the "printers" application, but not documents from other programs (libreoffice, qpdfview, atril; the job is sent to the printer and appears as completed in the print queue window but nothing is actually printed).

The printer works fine with MS Windows.

Is there anything else I could try?

Maybe revert the cups package to a previous version somehow?

0

Which version of Ubuntu are you using exactly? lsb_release -a and uname -a.

It sounds like your cups is working fine, but is something that is connecting you applications to CUPS. I never-the-less would try removing/deleting your printer, rebooting your computer, and reinstalling it. Then try uninstalling cups, rebooting, reinstalling.

Does your printer have a network port? If it does you might to try printing through the printer's built in print server.

Have you tried installing the Ubuntu Enablement Stack? This will give you a more modern Kernel, 4.2, and other stuff.

https://wiki.ubuntu.com/Kernel/LTSEnablementStack

  • I've tried your suggestions but nothing has worked so far. It doesn't have a network port, only usb. Distributor ID: Ubuntu Description: Ubuntu 14.04.4 LTS Release: 14.04 Codename: trusty Linux xfiles 4.2.0-36-generic #41~14.04.1-Ubuntu SMP Tue Apr 19 17:03:32 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux – Asta86 May 17 '16 at 21:24
  • I would get a different laser printer, like one from HP or Samsung, which have decent linux support. My preference is for HP. I have had really good experiences with their linux drivers for the past 15 years. hplipopensource.com/hplip-web/models/laserjet/… – David May 17 '16 at 21:50
  • I reinstalled every cups-related package in my system, rebooted once again and reinstalled the drivers, and it printed a couple of documents just fine. I hope it lasts, but I'll keep it in mind the next time I'm looking for a printer. I don't exactly know what solved the issue either, but thanks for your concern. – Asta86 May 17 '16 at 23:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.