7

In Ubuntu 14.04, I was able to change my Plymouth Theme simply by going to /lib/plymouth/themes and copy my theme in there.

Then, by simply typing sudo update-alternatives --config default.plymouth (choosing the accordingly number of my theme) and sudo update-initramfs -u, I was able to change my Plymouth theme.

In Ubuntu 16.04 LTS, the folder /lib/plymouth/themes does not even exist.

By seraching in Nautilus, I was able to find the folder /usr/share/plymouth and place my theme under themes. Then, by typing in the shell the commands above, I was, theorically, able to change my Plymouth theme to my pre-copied one.

The truth is that, after changing the Plymouth theme to my own and after several reboots, no Plymouth theme is showed at boot. Just a black screen appears and then lightdm shows up and I login to my account...

I'm using burg as my default bootloader.

  • I'm using grub2. Same problem for me too. In my case this is because fsck is running for too long on boot, and it runs before plymouth theme. – kashish Aug 20 '16 at 0:27
2

I ran into a similar thing. After using synaptic to find the default plymouth theme, I hit properties to see what files were installed. That listed most files going into this directory

/usr/share/plymouth/themes

put all you files there then run

update-alternatives --install /usr/share/plymouth/themes/default.plymouth default.plymouth /usr/share/plymouth/themes/"path/to-your-plymouth.plymouth" 100
|improve this answer|||||
  • Already tried that command. It only replaces the Plymouth Theme when Shutting Down, but on boot, nothing happens... – Gonçalo Fernandes May 28 '16 at 11:56
  • i moved a small collection of manually installed themes from /lib/ to /usr/ then did a rought and ready find /usr/share/plymouth/themes/ -maxdepth 2 -mindepth 2 -name "*.plymouth" -exec sudo update-alternatives --install /usr/share/plymouth/themes/default.plymouth default.plymouth {} 100 \; to make sure all themes in the \usr\ folder were added (it also sets existing ones to priority 100 regardless of what they were) – northern-bradley Sep 6 '18 at 12:27
2

These changes are read from the disk during shutdown, which is why that works.

On bootup, however, they are read from the initial in-memory file system image - initramfs, which you haven't updated with your changes. This is necessary because your regular file system isn't yet available.

Here's what I did to solve that in Ubuntu 14.04, so I can't guarantee it works for 16.04, but this command won't do any damage so it's worth a try.

If you run:

sudo update-initramfs -u

your changes will be put into place.

|improve this answer|||||
  • Could you offer the references for having to update the initramfs? – Braiam Jul 15 '16 at 17:08
  • Sorry, only other long forgotten posts on some forum or another (possibly this one, but not likely). But I did this on 14.04 under the same circumstances and it worked for me, so I noted it in my installation notes (which I keep for each OS). And, as I said, it may or may not work on 16.04; the reason I say it won't do any damage is that the command simply builds/assembles the ram file system image based on various entries and, if they haven't changed, neither will the ram file system ... – FrankO Jul 16 '16 at 21:30
  • Updating initramfs worked for me... I don´t know why, but update-initramfs -u is working to update plymouth theme. – Ear3ndil Nov 15 '16 at 10:30
  • initramfs is the virtual disk image loaded first when you boot your system. And thats where plymouth runs from. If you don't update it, the system won't know that you have changed preferences. – Soren A Dec 28 '16 at 10:27
0

Have a look at Unable to use a custom splash screen in Ubuntu 16.04LTS (waTeim and mac answers). It should work.

For more info, Check this out for installation and troubleshoot of plymouth themes in Ubuntu 16.04. http://rajeshksv.blogspot.in/2017/02/customize-ubuntu-linux-plymouth-splash.html (I have added all installation and troubleshooting at one place since many blogs in internet are outdated)

|improve this answer|||||
0

Open Nautilus as root by executing:

sudo -H nautilus

in the terminal and just go to /usr/share/plymouth/themes/ and then open the theme's folder and edit the .plymouth file using gedit.

In the .plymouth file, change the

[script]
ImageDir=/lib/plymouth/themes/themename
ScriptFile=/lib/plymouth/themes/themename/themename.script

to

[script]
ImageDir=/usr/share/plymouth/themes/themename
ScriptFile=/usr/share/plymouth/themes/themename/themename.script

replacing themename with the name of the theme.

For example the theme's name is darwin so the edits should be:

[script]
ImageDir=/lib/plymouth/themes/darwin
ScriptFile=/lib/plymouth/themes/darwin/darwin.script

to

[script]
ImageDir=/usr/share/plymouth/themes/darwin
ScriptFile=/usr/share/plymouth/themes/darwin/darwin.script
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.