1

I'm running 16.04 with Ethernet connection set to automatically connect to my VPN at start up in Network Manager (NM).

Network Manager Setting General

However, the NM password window appears at the Ubuntu login screen asking for the VPN password and blocks entering my Ubuntu password. After cancelling the NM window 3 times it goes away and I login to Ubuntu with my user password. I then have to select the Ethernet connection from NM in the system tray and connection proceeds without having to enter the VPN password (because the gnome2 key ring has the VPN connection password).

I would like to be able login to Ubuntu without interference from NM and have NM automatically connect to the VPN.

1

VPN Autoconnect states that "It seems that NetworkManager fails to obtain the user's VPN password from gnome-keyring-daemon."

it also states a possible workaround.

  • I understand the dilemma now. Setting the Ethernet connection in Network-Manager to "Automatically connect to VPN when using this connection" requires access to my VPN passwords stored in Seahorse. Seahorse is locked (encrypted) until I enter my system credentials. By changing "password-flags=1" to "password-flags=0" in the VPN configuration file in /etc/NetworkManager/system-connections, Network-Manager adds "password=XXXX" to that configuration file where XXXX is your VPN connection password in plain text. Not ideal, but acceptable. – brett May 23 '16 at 12:57
  • ... however, setting "All users may connect to this network" to off (unchecked) in Network-Manager delays opening the default connection until after login but the auto connect feature in Network-Manager does not work unless password-flags=0 which points to a bug in Network-Manager. – brett May 23 '16 at 13:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.