1

I have spent some time searching around the various threads relating to headphone issues in Ubuntu and none of the answers seem to resolve my issue, so I will post it here. This problem started a couple of months back when I was running 15.10, and persists now that I am running 16.04 (upgrade, not clean install).

Whenever I plug headphones into my laptop (Asus X202E-DH31T-SL) there is a strange noise (rising then falling static, followed by a loud pop) and then no sound. Sound comes through the built-in speakers fine, and goes out over HDMI fine. The headphones work with other devices. I have tried several pairs of headphones all to the same effect. Upon plugging the headphones in a dialog now appears stating 'unknown audio device'.

A dump of ALSA info can be found here.

I have tried the following:

  1. Checked alsamixer sound levels - no issues.
  2. Made changes to /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf as listed here. No success.
  3. Made changes to /etc/modprobe.d/alsa-base.conf as listed here, and tried multiple values for model as listed under the ALSA model list. No success. Each time I did a sudo alsa force-reload and unplugged/reinserted headphones, to absolutely no avail.
  4. Removed and re-installed both alsamixer and pulseaudio but this was not successful.

A dump from dmesg can be found below :

[    8.261817] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC269VB: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[    8.261825] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    8.261829] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x1a/0x0/0x0/0x0/0x0)
[    8.261832] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[    8.261835] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    8.261839] snd_hda_codec_realtek hdaudioC0D0:      Mic=0x12
[    8.273953] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[    8.274480] ieee80211 phy0: Atheros AR9485 Rev:1 mem=0xffffc90000d00000, irq=17
[    8.290195] input: HDA Intel PCH Headphone Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input13
[    8.290321] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input14

Any help much appreciated. I'm at the end of my efforts here, with the next stop being a wipe and clean install to see if that resolves the issue. I'd prefer not to do that.

protected by Community Aug 4 '16 at 5:30

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.