I have a dual-boot ThinkPad Edge E330 laptop (Ubuntu 14.04 /win10). I have had so far no problems with Ubuntu. This morning I started my session and I noticed that the laptop was not even trying to connect to the wifi network. No trace of connection is found after plugging the ethernet wire, either. In my previous session I just had a console apt-get upgrade. In windows, everything is just fine, so I suspect a damaged driver for the PCIe card. My current kernel is 3.13.0-46-generic The following info should be relevant:

sudo lshw -c network

   description: Network controller
   product: BCM43228 802.11a/b/g/n
   manufacturer: Broadcom Corporation
   physical id: 0
   bus info: pci@0000:02:00.0
   version: 00
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list
   config: driver=bcma-pci-bridge latency=0
   resources: irq:17 memoria:f1500000-f1503fff

 *-network DEACTIVATED
      descripction: Ethernet interface
      product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
      manufacturer: Realtek Semiconductor Co., Ltd.
      phys. id: 0
      bus info: pci@0000:08:00.0
      logical name: eth0
      version: 07
      serie: 3c:97:0e:e5:7d:ec
      size: 1Gbit/s
      capacity: 1Gbit/s
      width: 64 bits
      clock: 33MHz
      capabilities: pm msi pciexpress msix vpd bus_master cap_list   ethernet     physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   config: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full latency=0 link=no multicast=yes port=MII speed=1Gbit/s
   resources: irq:43 ioport:2000(size=256) memory:f0c04000-f0c04fff memory:f0c00000-f0c03fff

ifconfig -a

     eth0      Link encap:Ethernet  adressHW 3c:97:0e:e5:7d:ec  
               DIFUSION MULTICAST  MTU:1500  Métrica:1
               Packets RX:0 errors:0 lost:0 overruns:0 frame:0
               Packets TX:0 errors:0 lost:0 overruns:0 carrier:0
               colisions:0 long.colaTX:1000 
               Bytes RX:0 (0.0 B)  TX bytes:0 (0.0 B)

   lo        Link encap: local loop  
             Address inet:  Mask:
             Address inet6: ::1/128 Range:Host
             ACTIVE WORKING LOOP  MTU:65536  Metric:1
             Packets RX:1153 errors:0 lost:0 overruns:0 frame:0
             Packets TX:1153 errors:0 lost:0 overruns:0 carrier:0
             colisions:0 long.colaTX:0 
             Bytes RX:103441 (103.4 KB)  TX bytes:103441 (103.4 KB)

lspci -vvnn | grep -i net

02:00.0 Network controller [0280]: Broadcom Corporation BCM43228 802.11a/b/g/n [14e4:4359]
   Subsystem: Broadcom Corporation Device [14e4:0607]
08:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd.      RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev07)

sudo rfkill list all

  1: tpacpi_bluetooth_sw: Bluetooth
      Soft blocked: yes
      Hard blocked: no

It looks very similar to 14.04 - Network manager stopped working, but here the system does not display any internal error, and the drivers may add some extra dificulties.

Please, keep in mind that I can only try offline solutions. And thank you so much for your help!!


I had the same thing happen to me this morning. I had to go to another network working linux machine and execute these commands to save the pre-upgrade packages to a usb stick:

$ wget http://mirrors.kernel.org/ubuntu/pool/main/libn/libnl3/libnl-3-200_3.2.21-1_amd64.deb
$ wget http://mirrors.kernel.org/ubuntu/pool/main/libn/libnl3/libnl-route-3-200_3.2.21-1_amd64.deb
$ wget http://mirrors.kernel.org/ubuntu/pool/main/libn/libnl3/libnl-genl-3-200_3.2.21-1_amd64.deb

Then, insert the usbstick in the problem machine, mount it, cd the directory where your files are and execute the command:

$ sudo dpkg -i libnl-*.deb

...and the reboot. That should fix your network issue.

Ubuntu will then want you to upgrade those packages again. I did that and it broke mine again but someone else reported that more packages came up to upgrade and upgrading all of them fixed the original issue.

  • Thanks, but not yet. I tried this, and I had an interesting finding: with the old kernel and your remedy, at least I could see the light blinking in the ethernet port. I upgraded to more recent kernels (3.14.60 and 4.2.0) and the ethernet port was dead as soon as the system was booted and the login screen appeared. Would you recommend a complete downgrading? – ARid May 17 '16 at 20:59

P. Miller's answer put me in the right track. It is solved now. What I finally did is:

  1. To downgrade the libn libraries as suggested. Although it is not necessary, I also downgraded the kernel to the previous version. This had my ethernet port blink again, but I had no connectivity yet.

  2. For the ethernet I wrote

    sudo ifconfig eth0 up
    sudo dhclient eth0

    This is not permanent, but you can edit /etc/rc.local (sudo gedit /etc/rc.local) and insert sudo dhclient eth0, so that the final result is:

     #!/bin/sh -e
     # rc.local
     # This script is executed at the end of each multiuser runlevel.
     # Make sure that the script will "exit 0" on success or any other
     # value on error.
     # In order to enable or disable this script just change the execution
     # bits.
     # By default this script does nothing.
     sudo dhclient eth0
     exit 0

    After rebooting, ethernet was working again.

  3. Recovering the wifi took longer. In my case, being a Broadcom card, the usual b43 driver did not work, while the suggested one in Software and updates -> Additional drivers, did (bcmwl-kernel-source). Just click to accept the suggestion. In principle, it will produce the file /etc/modprobe.d/blacklist-bcm43.conf blacklisting the rival modules. To make sure that there are no interferences from b43, you can type

    sudo modprobe -rv b43

    Dependencies are updated with

    sudo depmod -a

    Finally, to access the missing wifi icon in the taskbar (nm-applet), I did as in other threads:

    sudo apt-get install indicator-applet indicator-network
    sudo apt-get install --reinstall network-manager-gnome

Once again, after a final reboot, wifi was back again. I hope this can help you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.