I have read all related questions but none of those answers worked for me. So the problem is that on my ubuntu 14.04, there isn't network connection and no network icon either. I have used ubuntu over 6 months now and this is first time when there is network problems. I have tested all kind of network-manager start, stop, restart, I have downloaded wicd-1.7.0 (for someone wicd made the trick) and pretty much everything what the answers are mentioned for those related questions.

The newest solution I found is to download three packages libnl-3-200 libnl-genl-3-200 libnl-route-3-200 I downloaded them, manually. Then I go to the new folder where those packages located and run sudo dpkg -i lib*.deb and then reboot the system and after that I saw following pop-up message: enter image description here

When I saw that message after reboot, I was sure that the solution solved my issue, but it didn't. After I click "Run" next pop-up message popped and crushed my soul instantly: enter image description here

And once again I have no idea how I could make this work. Please let me know if I can provide more information or something. Thank you!

  • WICD has no tray icon. – mchid May 16 '16 at 6:49
  • Please don't download software, please use apt-get instead: sudo apt-get update; sudo apt-get install libnl-3-200 libnl-genl-3-200 libnl-route-3-200 – mchid May 16 '16 at 6:51
  • @mchid no difference. I'm still stuck. The problem is the libnl-*.deb but even if I change those 3-200 to the /var/cache/apt/archives and install them there. Network doesn't work. Weird – G.Ball May 16 '16 at 9:46

I entered the following command in terminal

sudo apt-get install network-manager

This forced network-manager to upgrade itself.

Now networking is running

  • Thank you Shawn. This doesn't fix'd my problem instantly but this pushed me to the correct direction. And after few hours package downloading and installation I finally got the correct network version and then I started modify USB setting to get network connection. Anyway, at the end of the day. My network finally works again on my Ubuntu machine! – G.Ball May 17 '16 at 7:17

I had the same problem a few days ago when I allowed a routine upgrade. After the reboot I could get no internet connection.

When I checked the Error Report it was trying to send, I found out that the Network Manager had crashed (not compatible with this version).

1) First I used the following command to find out what the latest installs had been:

tail -n25 /var/log/apt/history.log

The install had included:

  • libnl-3-200_3.2.21-1ubuntu1_amd64.deb
  • libnl-genl-3-200_3.2.21-1ubuntu1_amd64.deb
  • libnl-route-3-200_3.2.21-1ubuntu1_amd64.deb

which I determined were related to the Network Manager

2) With further searching I found the page (see link below) that told me I could copy the previous version files into the apt-get archives and install them:

2.1) moved out the files (above) from /var/cache/apt/archives

2.2) Downloaded and copied into /var/cache/apt/archives:

  • libnl-3-200_3.2.21-1_amd64.deb
  • libnl-genl-3-200_3.2.21-1_amd64.deb
  • libnl-route-3-200_3.2.21-1_amd64.deb

2.3) Then install each from that directory with:

dpkg -i libnl-3-200_3.2.21-1_amd64.deb libnl-genl-3-200_3.2.21-1_amd64.deb libnl-route-3-200_3.2.21-1_amd64.deb

2.4) Restart Ubuntu and voila! All good again. I suspect that you didn't put the files in the correct location.

This is the link to the article mentioned above that I found helpful. Note that it talks about 'proposed repository' but this was not the case for me.

I also found this post about how to lock the version of the libnl apps (note that I locked everything that had libnl in the app name, so that was a total of 19 files)

  • a couple of other posts have the same-ish solution: askubuntu.com/questions/771627/… and askubuntu.com/questions/772838/… – Ian F. Hood May 16 '16 at 7:31
  • Thank you for your advise. In the /var/cache/apt/archives I have at the moment Partials (empty folder) | lock | libnl-3-200_3.2.21-1_amd64.deb | libnl-genl-3-200_3.2.21-1_amd64.deb | libnl-route-3-200_3.2.21-1_amd64.deb . And I installed each from that directory and after that I reboot the system but no difference. Still the same. I'm reading those articles which you provided but no luck so far. Should I locate those libnls in the Partials folder or should it be empty ? – G.Ball May 16 '16 at 7:49
  • I will check out those questions URLs – G.Ball May 16 '16 at 7:51
  • @lan F. Hood none of those worked. – G.Ball May 16 '16 at 8:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.