i can't get my laptop WiFi up and running with ubuntu (Kernel 4.4.0-22-generic).

I have a Qualcomm Atheros 168c:0042 pci adapter.

Things I already tried:

  • The solution from this question (installing the firmware from git repo): Qualcomm Atheros Device [168c:0042] (rev 30) Wi-Fi driver installation
  • I also tried using another Kernel (4.5 & 4.6), which showed some result. There was a menu which i could use to connect to my WiFi, but i still could not use the connection (no internet).
  • Install a backport (like described in the question above)
  • Format c:

Is there something new i could try??? I'm kind of desperate, because i already invested round about 8-10 hours into the matter =/ Any help is appreciated!


Infos:

cat /proc/version

Linux version 4.4.0-22-generic (buildd@lcy01-32) (gcc version 5.3.1 20160413 (Ubuntu 5.3.1-14ubuntu2) ) #39-Ubuntu SMP Thu May 5 16:53:32 UTC 2016

dmesg | grep ath10k

[    5.342231] ath10k_pci 0000:02:00.0: pci irq msi interrupts 1 irq_mode 0 reset_mode 0
[    5.610265] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/cal-pci-0000:02:00.0.bin failed with error -2
[    7.859610] ath10k_pci 0000:02:00.0: qca9377 hw1.0 (0x05020000, 0x003820ff sub 1a3b:2231) fw WLAN.TF.1.0-00267-1 fwapi 5 bdapi 2 htt-ver 3.1 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1 features ignore-otp
[    7.859619] ath10k_pci 0000:02:00.0: debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[    7.925725] ath10k_pci 0000:02:00.0 wlp2s0: renamed from wlan0

sudo lshw -c network

*-network
description: Wireless interface product: Qualcomm Atheros vendor: Qualcomm Atheros physical id: 0 bus info: pci@0000:02:00.0 logical name: wlp2s0 version: 30 serial: 80:a5:89:02:1a:d9 width: 64 bits clock: 33MHz capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless configuration: broadcast=yes driver=ath10k_pci driverversion=4.4.0-22-generic firmware=WLAN.TF.1.0-00267-1 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn resources: irq:317 memory:81000000-811fffff *-network description: Ethernet interface physical id: 1 logical name: bnep0 serial: 80:a5:89:02:1a:d8 capabilities: ethernet physical configuration: broadcast=yes ip=192.168.44.105 multicast=yes

lshw -vvnn

02:00.0 Network controller [0280]: Qualcomm Atheros Device [168c:0042] (rev 30)
Subsystem: AzureWave Device [1a3b:2231]
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx+
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 317
Region 0: Memory at 81000000 (64-bit, non-prefetchable) [size=2M]
Capabilities: <access denied>
Kernel driver in use: ath10k_pci
Kernel modules: ath10k_pci

Upgrade the kernel to linux-image-extra-4.13.0-1005-azure-edge

Worked first time:-)

  • are you sure the problem this solved for you was the same as OP's? Can you clarify at all? – Zanna Jan 19 at 10:53

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.