0

My Acer Aspire V5-571P running Ubuntu 16.04 has started rebooting a couple of seconds after shutdown completes. It seems that this is an issue that keeps cropping up randomly in Ubuntu?

I've tried the 'laptop-mode-tools' install, and that doesn't seem to have affected it, but nothing I've found has explained in sufficient detail what changes need to be made - can anyone expand?

I've tried the edit to /etc/default/grub, as described in this answer, but that didn't help at all. In fact it made things worse. The shutdown screen just hung, and on boot, the purple wash was corrupted, and there was a large amount of commandline messages before the OS would fully boot. I've removed the acpi=noirq text from the file.

The BIOS 'Wake-on-LAN' setting is DISABLED.

I've created the script found here: https://www.behnke.io/fedora-17-on-an-aspire-v5-571-reboot-on-shutdown/, but when I run the last update :

sudo chkconfig --add haltusbpower

I get the response: sudo: chkconfig: command not found, and I'm not sure what to make of it....

Does anyone have any more suggestions?

Additional Testing.

It definitely seems to be something to do with the USB ports - or PORT. 1 in particular (which seems very odd). If this particular port has a usb key of some sort in it, the laptop will shut down.

Preliminary testing seems to show that it doesn't matter what it is - I've tried it with a Logitech Universal Key (for a trackball), and a Sandisk Cruzer Fit (4Gb). Weirdly, (I need to check this a few more times), but if one of the other 2 USB ports is used, it doesn't seem to make a difference. I'm stumped. Happy enough to have an empty key in a port for the time being though to ensure the laptop shuts down fully.

Further comment:

I installed Apache2 today and at the end of the install there were the following warnings:

insserv: Script haltusbpower is broken: incomplete LSB comment.
insserv: missing `Required-Start:' entry: please add even if empty.
insserv: missing `Required-Stop:'  entry: please add even if empty.
insserv: missing `Default-Start:'  entry: please add even if empty.
insserv: Default-Start undefined, assuming empty start runlevel(s) for 
script `haltusbpower'
insserv: Script haltusbpower is broken: incomplete LSB comment.
insserv: missing `Required-Start:' entry: please add even if empty.
insserv: missing `Required-Stop:'  entry: please add even if empty.
insserv: missing `Default-Start:'  entry: please add even if empty.
insserv: Default-Start undefined, assuming empty start runlevel(s) for 
script `haltusbpower'

I looked up the warning and found this on softpanorama

Would this have something to do with the haltusbpowerscript not working as intended?

For Reference - if anyone else has this issue, I ended up just living with the issue by keeping a Sandisk Cruzer Fit permanently plugged in.

  • If the solutions in other Q&As here didn't work for you, then this isn't a duplicate. Just link to what you've tried so others don't mark it without knowing you've tried those solutions. – TheWanderer May 15 '16 at 20:36
  • I would recommend making sure you have the latest BIOS update from ASUS Support (and if you don't, to re-flash your BIOS). This often fixes a lot of mysterious power management issues. – Nick Weinberg Jul 10 '16 at 9:07
  • are you using multiple OS? – Gahan Oct 7 '17 at 5:59
1

After several hours trying to solve this, I was able to find a final solution to my Acer Aspire V5-471.

I have tried everything which I found in internet with no results in Mint 18.2 64 bits (grub options, wake up in bios, wifi configuration, laptop-mode-tools, kernel update, etc, etc). After a searching in usb issue, I just put that in /etc/rc.local above the existing line that says exit 0:

for usb_ports in /sys/bus/usb/devices/usb?/power/control; do 
   echo on > $usb_ports
done

It did the trick and I finally could shut down my computer!

0

If it helps, try shutting it down by shutdown command in terminal. I do the same with my Acer Aspire V5-571p.

  • that doesn't work always – Gahan Oct 7 '17 at 5:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.