0

This question already has an answer here:

I recently tried to install npm and nodejs and got some errors and was suggested to run sudo apt-get update.

After running sudo apt-get update I get the following error:

 Failed to fetch http://archive.ubuntu.com/ubuntu/dists/trusty/Release  Unable to find expected entry 'universe/binary-amd64/Packages' in Release file (Wrong sources.list entry or malformed file)

 E: Some index files failed to download. They have been ignored, or old ones used instead.

The output of cat /etc/apt/sources.list is :

deb http://archive.ubuntu.com/ubuntu trusty main universe restricted multiverse

marked as duplicate by karel, TheWanderer, Zanna, Pilot6, David Foerster Oct 27 '16 at 10:10

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

This is because most of your PPA are outdated or doesn't exist anymore.

Look at your /etc/sources.list (or the files in /etc/sources.list.d) and remove or fix those lines that cause the error.

Also have a look at this answer by fossfreedom for a good and detailed explanation and it will help you.

  • Tried this and it didn't work. It told me no ppas to be removed – jon May 18 '16 at 8:48
  • Try another archive mirror. You can change the server location in System Settings, Software&Updates, Download from:. Maybe the file on the server you currently use is broken. The problem might also go away then after a few hours or days if that was the case. – Sinscary May 18 '16 at 12:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.