What I want to achieve:

I want to customize my complete boot of my Ubuntu 16.04 LTS installation to show the same wallpaper which is actually on my desktop.

What I achieved till now:

  • added the wallpaper to the grub menu by adding the following lines to /etc/deault/grub and doing an update-grub afterwards.

    export GRUB_MENU_PICTURE="/boot/grub/wallpaper.png"
    export GRUB_COLOR_NORMAL="white/black"
    export GRUB_COLOR_HIGHLIGHT="black/white"
  • added the wallpaper to the splash-screen and login screen


When I boot up the picture is showing while in grub, but then I rarely see the splash screen, instead I get an almost blank screen showing the file-system check like following:

/dev/sda1: clean, 201776/60878736 files, 4991277/243040256 blocks

This prevents me from having the boot experience I want to achieve since after that the splash-screen just shortly popping up after that message.


How can I remove this message from showing up so I get a seamless booting with my beloved wallpaper, without switching the file-system check completely off (if possible)?


Silencing boot messages

You should be able to achieve this with the kernel parameter loglevel= or quiet

loglevel=       All Kernel Messages with a loglevel smaller than the
                console loglevel will be printed to the console. It can
                also be changed with klogd or other programs. The
                loglevels are defined as follows:

                0 (KERN_EMERG)          system is unusable
                1 (KERN_ALERT)          action must be taken immediately
                2 (KERN_CRIT)           critical conditions
                3 (KERN_ERR)            error conditions
                4 (KERN_WARNING)        warning conditions
                5 (KERN_NOTICE)         normal but significant condition
                6 (KERN_INFO)           informational
                7 (KERN_DEBUG)          debug-level messages

quiet       [KNL] Disable most log messages

I am not sure at exactly what level this would be hidden (or how quiet you would like your boot to be).


reboot your computer, and at the grub menu hit e to edit the boot parameters.

scroll down to the end of the linux... line using the arrow keys

add desired loglevel parameter or quiet to the end of that line. example:

linux      /vmlinuz-4.4.0-21.generic.efi.signed root=/dev/mapper/encrypted ro loglevel=4


linux      /vmlinuz-4.4.0-21.generic.efi.signed root=/dev/mapper/encrypted ro quiet

when done editing, proceed to boot by pressing F10


To do this, edit /etc/default/grub


uncomment it if needed, and add the desired log level or quiet -- for example GRUB_CMDLINE_LINUX_DEFAULT="loglevel=4" or GRUB_CMDLINE_LINUX_DEFAULT="quiet"

and run sudo update-grub

fsck messages

remove fsck from initramfs

fsck is run by default by the initramfs. by removing it and having systemd run fsck we will be able to redirect the output.

see man initramfs and wiki.ubuntu.com/Initramfs for more info on removing fsck from the ramfs.

systemd fsck

From the arch wiki:

Now copy the files systemd-fsck-root.service and systemd-fsck@.service located at /usr/lib/systemd/system/ to /etc/systemd/system/ and edit them, configuring StandardOutput and StandardError like this:



In Ubuntu, these files are both located in /lib/systemd/system

If the file system is not checked by the initramfs during boot, systemd-fsck-root.service will automatically be run.

see http://manpages.ubuntu.com/manpages/wily/man8/systemd-fsck@.service.8.html

  • In fact I have the following grub parameters set already but is still shows the fsck message. Here my parameters: GRUB_CMDLINE_LINUX_DEFAULT="quiet loglevel=0 splash" – Videonauth Jun 8 '16 at 18:37
  • it couldn't hurt to boot and verify that these are in the kernel parameters by pressing e at the boot grub menu. If they are, I'm not sure what the solution would be. – Paul Jun 8 '16 at 18:39
  • They are set, just rebooted to make sure, its really a pain the grub menu shows my picture, the spash screen shows my picture and the login greeter as well but while booting it blacks out and shows the fsck message – Videonauth Jun 8 '16 at 18:41
  • see this post in the arch forums: wiki.archlinux.org/index.php/Silent_boot for a possible workaround.I am not exactly certain right away how to adapt it to ubuntu – Paul Jun 8 '16 at 18:43
  • 2
    I could be wrong, but I am not sure that there is such an elegant way to accomplish it in ubuntu. It doesn't appear that ubuntu has those services by default to move. man initramfs.conf will help you to understand how to remove fsck from the ram fs. wiki.ubuntu.com/Initramfs has more info on generating your own ram fs. – Paul Jun 8 '16 at 18:54

Removing Checking Disks From 20.04 Boot

Installed system

The command line option fsck.mode=skip can be used to skip the disk check when booting Ubuntu 20.04.

The line Checking disks: 0% complete may still come up but fsck will not be run, nor will boot time be increased.

Add fsck.mode=skip to the linux line in grub.cfg just before quiet splash

It is recommended to add the command to grub.cfg by editing /etc/default/grub thus: GRUB_CMDLINE_LINUX_DEFAULT="fsck.mode=skip quiet splash" and then run sudo update-grub.

I have had this problem with a Live USB but not with an installed system.

Persistent USB's

The command line option fsck.mode=skip can also be used to skip the disk check on persistent USB drives.

The line Checking disks: 0% complete will still come up but fsck will not be run, nor will boot time be increased.

mkusb After the Persistent USB drive is created, open /boot/grub/grub.cfg as root.

  • Add fsck.mode=skip to the Persistent menuentry thus:

linux ($root)/casper/vmlinuz file=/cdrom/preseed/ubuntu.seed maybe-ubiquity fsck.mode=skip quiet splash persistent ---

  • Newer versions of mkusb already include this fix

UNetbootin After creating the boot drive, open /boot/grub/grub.cfg as root.

  • Add fsck.mode=skip to the first menuentry for (UEFI boot mode).

  • Open syslinux.cfg as root and add fsck.mode=skip to the default menuentry for (BIOS boot mode).

Rufus After creating the boot drive, open /boot/grub/grub.cfg as root.

  • Add fsck.mode=skip to the Default menuentry for (UEFI boot mode).

  • Open /isolinux/txt.cfg as root and add fsck.mode=skip to the "Try Ubuntu without installing" menuentry, (for BIOS boot mode).

The Try Ubuntu / Install Ubuntu screen can be removed from BIOS boot by overwriting syslinux.cfg with:

default persistent
label persistent
  say Booting an Ubuntu Persistent session...
  kernel /casper/vmlinuz
  append  file=/cdrom/preseed/ubuntu.seed boot=casper persistent initrd=/casper/initrd quiet splash noprompt --

I too have been experiencing black screen after grub with console logging and a flash of Plymouth splash screen even on a fresh install of 16.04 LTS. Disabling messages is probably not the best thing to do. I Google searched outside of ask Ubuntu and discovered this thread. In comment #18 you'll find the commands that fixed my issue with out disabling messages.

My procedure for implementing the fix went as follows:

  1. Open Terminal (You will have to be logged in as root)
  2. Type: sudo -i (type your administrator password)
  3. Type: echo FRAMEBUFFER=y > /etc/initramfs-tools/conf.d/splash
  4. Type: update-initramfs -u
  5. Type: exit (to log out as root).
  6. Close your terminal and reboot your computer.

Now if Plymouth is working properly, proceed with customizing your boot process. If you have tried many attempts to fix the Plymouth splash screen with terminal commands I suggest a fresh install and start over, you may have caused damage to your file system and not be aware of it.

  • Thank Eric for cleaning things up and making it look nice – Joe Wicz Nov 18 '17 at 5:51
  • Also worked for me on fresh Lubuntu install – Joe Wicz Feb 12 '18 at 19:43
  • When starting up Plymouth when should Plymouth take over for the boot manager? For the first 25 seconds I just get a white screen then boot finishes quickly before Plymouth displays much. – ZeroPhase Jul 16 '19 at 4:01
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash loglevel=3 console=tty3"

console=tty3 moves fsck output to not default console and keep tty1 clean.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.