4

The CuraEngine allows to convert the .stl files to .gcode

I am new to 3d printing, is any one familiar with curaEngine.

Can I have a example of commandLine Creation of gcode. Or can anyone suggest me a tool for converting stl files to gcode via command line in ubuntu

1

supporse you are running the curaengine on ubuntu14.04LTS. according to the curaengine manual

git clone
    https://github.com/Ultimaker/CuraEngine.git
    https://github.com/google/protobuf.git
    https://github.com/Ultimaker/libArcus.git

compile the protobuf

arrording to https://github.com/Ultimaker/CuraEngine#installing-protobuf, you can success this step.

compile the libArcus according to https://github.com/Ultimaker/libArcus#installing-protobuf

but when you run the make .., you will come to an error. ~/libArcus/build$ cmake ..

CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:108 (message):
  Could NOT find PythonLibs (missing: PYTHON_LIBRARIES) (Required is at least
  version "3.4")
Call Stack (most recent call first):
  /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:315 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake-2.8/Modules/FindPythonLibs.cmake:208 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:11 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/lufei/libArcus/CMakeFiles/CMakeOutput.log".

then sudo apt-get install python3-dev

the key step is install the pip

wget https://sourceforge.net/projects/pyqt/files/sip/sip-4.18.1/sip-4.18.1.tar.gz
tar xzvf sip-4.18.1.tar.gz
cd sip-4.18.1
python3 ./configure.py
make
sudo make install

comment the 28th line ../cmake/FindSIP.cmake to ignore the pythonn-dev check, as you have install the python3-dev. then you can sussecc compile the libarcus.

compile the curaengine to compile curaengine you need g++ 4.8, while g++4.8 install in ubuntu14.04lts.

sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt-get update
sudo apt-get install gcc-4.9
sudo apt-get install g++-4.9
sudo ln -s /usr/bin/g++-4.9 /usr/bin/g++ -f
sudo ln -s /usr/bin/gcc-4.9 /usr/bin/gcc -f

when you compile the curaengine it will output ERROR ...., just ignore it. then everything done.

just run ./CuraEngine slice -j ~/prusa_i3.def.json -o output.gcode -l ~/source.stl the prusa_i3.def.json and the fdmprinter.def.json you need download from the cura repo.

| improve this answer | |
1

just run CuraEngine help It should be up to date...

Don't forget to take a look at fdmprinter.def.json to see all (300+) settings.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.