1

I have a Ubuntu 14.04.02. As I updated it,there was booting problem on my laptop.After some try it started.How I don't know.So I started fixing my grub as it was also not working. So after seeing some solutions : I did: fdisk is giving me : WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.

and also with Partition 1 does not start on physical sector boundary.

This is

~$ sudo fdisk -l

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1  1953525167   976762583+  ee  GPT
Partition 1 does not start on physical sector boundary.

Disk /dev/mapper/ubuntu--vg-root: 995.2 GB, 995190898688 bytes
255 heads, 63 sectors/track, 120991 cylinders, total 1943732224 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x00000000

Disk /dev/mapper/ubuntu--vg-root doesn't contain a valid partition table

Disk /dev/mapper/ubuntu--vg-swap_1: 4202 MB, 4202692608 bytes
255 heads, 63 sectors/track, 510 cylinders, total 8208384 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x00000000

Disk /dev/mapper/ubuntu--vg-swap_1 doesn't contain a valid partition table

I know something is wrong but don't know what.What is the cause and do I need to fix it? If so, how?

I have checked related links but nothing helped. The grub bootloader is also not coming and on startup after pressing ESC Key settings are coming which are also not working.

Don't know how to fix.Thanks in advance.

  • Please be more specific in your boot issue. Can you log into Ubuntu? Do you get any errors? – Gayan Weerakutti May 15 '16 at 15:29
1

You already got the answer:

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.

So use parted instead.

$ fdisk -l is for displaying partitions of a msdos disk. Since you have GPT you could use

$ sudo parted -l

  • 1
    You can also use gdisk which is the fdisk for gpt partitioned drives. And fdisk on 16.04, now does support gpt. rodsbooks.com/gdisk or just: sudo gdisk -l /dev/sda – oldfred May 15 '16 at 15:41
  • @oldfred Yeah any major disk utility would do. – Gayan Weerakutti May 15 '16 at 15:46
  • @reversiblean so it's nothing to worry about? right? i tried both sudo parted -l and sudo gdisk -l /dev/sda . – TARUN JOSHI May 15 '16 at 16:21
  • @TARUNJOSHI Just ignore the warnings. I'm not sure exactly what your problem though.. please be more specific in your questions – Gayan Weerakutti May 15 '16 at 16:24
  • @reversiblean my initials problem was this : askubuntu.com/questions/772716/… But don't how it booted and then I ran the above command and I found the problem. So asked . – TARUN JOSHI May 15 '16 at 16:29
0

the warning is just a warning. See WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted

Partition 1 does not start on physical sector boundary. Partition does not start on physical sector boundary?

also you have another error "Disk /dev/mapper/ubuntu--vg-root doesn't contain a valid partition table"

you ran boot-repair, do you have the bootinfo summary? it is the second option in boot-repair. it asks if you want to upload the summary to pastebin. this could help with fixing your grub

you could also try reinstalling grub2 https://help.ubuntu.com/community/Grub2/Installing

it might be quicker to boot from live usb and backup your files and reinstall ubuntu

  • I didn't ran boot-repair. so no summary. but my grub bootloader is not starting,I have tried to open GRUB boot loader by pressing SHIFT key while booting but nothing happened. I will try reinstalling grub2. – TARUN JOSHI May 15 '16 at 16:27
  • Makes a big difference if you have UEFI or CSM/BIOS. And if drive is gpt, you probably have UEFI boot. Make sure to always boot system & live installer as repair disk in UEFI boot mode. Make sure UEFI is on in UEFI/BIOS and BIOS/CSM boot mode is off. Or if install is BIOS/CSM, only boot in BIOS mode. – oldfred May 15 '16 at 17:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.