3

I am trying to create samba file server (Ubuntu 14.04) on my local network, I can connect to samba server from another Ubuntu 14.04 and enter the shared folder as a guest, but after creating a directory I'm getting following error:

Software caused connection abort

The point is that when I re-enter the shared folder I can see the created directory! So I have required write and read permissions,

I have tried different forms of configuration in smb.conf with no success, even when I share a directory by right-clicking and selecting local network share from the context menu, I will face the same error!

Also when I do the same procedure using smbclient:

NT_STATUS_CONNECTION_DISCONNECTED making remote directory \test
smb: \> SMBecho failed (NT_STATUS_CONNECTION_DISCONNECTED). The connection is disconnected now

3 Answers 3

6

According to the Arch wiki this might be caused by deactivation of SMB1. SMB1 is deactivated by default since Samba 4.11 (at least on Arch). Adding the following to /etc/samba/smb.conf might solve to error:

[global]
client min protocol = CORE
3
  • 1
    Thanks ! This is the answer that worked for me ! (ubuntu 20)
    – BiAiB
    May 18, 2020 at 12:32
  • The same on Manjaro. Thank you!
    – it3xl
    Jun 13, 2020 at 11:16
  • On Xubuntu, I had to run sudo apt install samba first, because the configuration file didn't exist.
    – Rafał G.
    Jul 13, 2020 at 18:47
4

In a security update (19 april 2016) a dependency has been forgotten. You have to update library libtalloc2 with apt-get install libtalloc2

0

After two weeks, I finally solved it.

The problem is that the new version of samba has a mind-blowing bug, so anyone who has a similar problem may want to use the following command to downgrade their samba:

sudo apt-get install samba=2:4.1.6+dfsg-1ubuntu2 samba-common=2:4.1.6+dfsg-1ubuntu2 \
  samba-libs=2:4.1.6+dfsg-1ubuntu2 samba-common-bin=2:4.1.6+dfsg-1ubuntu2  \
  samba-dsdb-modules=2:4.1.6+dfsg-1ubuntu2 python-samba=2:4.1.6+dfsg-1ubuntu2  \
  libldb1=1:1.1.16-1 python-ldb=1:1.1.16-1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .