1

I installed Ubuntu 14.04 LTS on Lenovo Think-pad laptop some months ago. Everything has been working fine until yesterday. Don't know whether something hasn't updated correctly. Very new to Ubuntu and non-technical. Tried following thread for this problem by following instructions:

Open Terminal

sudo apt-get install libappindicator1  

Pressed enter and received message that not all "information" could be recovered from archives, or something like that continued with the following instructions in Terminal:

sudo apt-get install --reinstall ubuntu-desktop  
sudo apt-get install unity  
sudo shutdown -r now  

After shutting down I restarted, but the network menu was still not there. Then I followed instructions in Ubuntu help to get error messages from Terminal as follows:

(nm-applet:2379): WARNING: Could not initialize NMClient /org/freedesktop/NetworkManager: The name org.freedesktop.NetworkManager was not provided by any .service files

(nm-applet2379): nm-applet-WARNING: Error connecting to ModemManager: Error calling StartServiceByName for org.freedesktop.Modem-Manager1: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ExecFailed: Cannot launch daemon,file not found or permission invalid

(nm-applet:2379): nm-applet-WARNING: Could not find ShellVersion property on org.gnome.Shell after 5 tries

(nm-applet:2379): nm-applet-WARNING: Failed to register as an agent: (2) The name org.freedesktop.NetworkManager was not provided by any .service files

Similar error messages were also generated in the Terminal before I tried the troubleshooting steps found in the thread but the nm-applet number was 2867, not 2379.

I only have Ubuntu installed on my Lenovo laptop but also run a separate laptop with MS Windows with no internet connection issues, so I know there is not problem with my Wifi.

1

I had a similar problem once and by changing nm-applet to launch with dbus-launch nm-applet solved my problem. To see if this will work for you, run in terminal

dbus-launch nm-applet

and see if network menu shows up. If menu shows than to make the fix permanent, edit

/etc/xdg/autostart/nm-applet.desktop

and change

Exec=nm-applet

to

Exec=dbus-launch nm-applet

Hope it will help you.

1

This is caused by a regression resulting network-manager not to be able to start. Here is the procedure to fix it (as this has already been fixed with an update):

  1. revert to an previous version
  2. start network service again
  3. Install the latest updates

Revert to an older version

Open your terminal and issue the following

sudo apt-get install libnl-3-200=3.2.21-1 libnl-route-3-200=3.2.21-1 libnl-genl-3-200=3.2.21-1

Note: if for some reason, the packages are not in the cache folder, you will need to download them from another computer:

Then open a terminal in the folder where you saved them and install them with

sudo dpkg -i libnl-*.deb

Start Network Service

sudo service network-manager start

Then you will be automatically connected to the internet

Reverting to an older version

Install the latest updates

sudo apt update && sudo apt upgrade

As you can see from the following changlog, this has been fixed and you can safely update

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.