10

There were a set of extra steps I needed to take with Ubuntu 14.04 that got Japanese text input working, but the same steps seem to not apply to 16.04. The system toggles between "En" and "Ja", but all it's doing (functionally) is switching from an English keyboard layout to a Japanese keyboard layout. I installed in English with my location in Japan, which triggered Japanese language support (which isn't working). I also tried a clean install in Japanese that installed all menus, etc. in Japanese, but also had non-functional Japanese input, so I did a third install in English again - with Japan as the local - which is where I stand now with it. Any help with this issue greatly appreciated, as I need to be able to input Japanese text.

  • Have you tried installing Japanese from Add and remove language – Hizqeel May 15 '16 at 8:40
  • Re: "Have you tried installing Japanese from Add and remove language" - Yes. It's shown as one of the installed languages, but input doesn't work. Input didn't even work with an installation done completely in Japanese! – TKLHS May 15 '16 at 11:57
  • help.ubuntu.com/lts/ubuntu-help/keyboard-layouts.html (see "Complex input methods") – Gunnar Hjalmarsson May 15 '16 at 12:04
  • GH - Thank you! I had actually done that before and none of the options worked, but when I went ahead and tried it again, this time there was the option "Japanese (Anthy) (IBus)" and that has done the trick! 日本語入力万歳!!! I'm quite sure it wasn't there before as I went there several times. In any case, it's there now, so this works (provided "Japanese (Anthy) (IBus)" is one of the options): 1) System Settings 2) Text Entry 3) Japanese (Anthy) (IBus) In-between not having Anthy as an option and it appearing, I installed some Japanese dictionaries, so maybe that helped? – TKLHS May 15 '16 at 12:25
12
  1. Open settings to add and remove a language, IBus should be shown as the default option.
  2. Choose to add Japanese, which automatically installs fcitx-mozc.
  3. When it's done, close the language window and reopen it. This time, fcitx will be available as an option, choose it.
  4. Log out, log in, and there should be a small keyboard icon on the upper right.
  5. Click it, and choose configure input method.
  6. Click on the add language button (a small plus button on your bottom-left corner.
  7. Uncheck the option to only show the current language (above the search bar), and type in mozc, which should show up the option mozc - Japanese.
  8. Click OK and you should be able to use Japanese in most applications by hitting ctrl + space
  • Tried a new installation (helping a friend) and with their machine, "Japanese (Anthy) (iBus)" never showed up, so we tried your suggestion with mozc and finally got Japanese input working. (日本語) I don't understand why "Japanese (Anthy) (iBus)" mysteriously appeared on my previous installation but not this time. Why can't Japanese input just work out of the box? In any case, thanks for your input, as what worked for my first installation didn't work this time around. (Incidentally, is there any difference between procedures for the 32-bit and 64-bit versions?) – TKLHS May 18 '16 at 9:07
  • Helped two people get set up lately. In the first case, we tried various things and finally got Japanese input working without really knowing why.... In the second case, steps #5-#7 above got it going. Now it's working, both users are happy, but why doesn't it work without jumping through those hoops? Many many years ago, with Suse Linux, you would choose a Primary Language and a Secondary Language. By choosing English as the primary language and Japanese as the secondary language, it just worked, with no hoops to jump through. It would be nice if this could be fixed someday.... – TKLHS Aug 18 '16 at 7:15
  • Glad that it helped you(and friends)..and yes there are differences between procedures for 32 and 64 bit versions.. It is still unsolved issue and as per ubuntu Wiki content# 8 and 9 its still in process..! If this answer helped you then you can mark it as Accepted :) – Hizqeel Aug 18 '16 at 9:29
  • I have since done a couple of installations with Ubuntu 16.04.1 LTS and the English installation required the steps you helped with, and (fortunately) the Japanese installation (with all menus in Japanese) just worked without having to do anything extra after installation. /// BTW: Re: "If this answer helped you then you can mark it as Accepted" - I'd be happy to do that, but don't see an "Accepted" anywhere on the page... How is that done? – TKLHS Sep 18 '16 at 6:35
  • 1
    Ah... found it! (This shows how old I am I guess. I'm still looking for words and not symbols!) – TKLHS Sep 22 '16 at 2:57

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.