7
  1. I have a router, Laptop with Ubuntu (my laptop), Win10-laptop (brother's), iPhone. All devices are connecting to router's Wi-Fi.
  2. The normal speed is 16-20 mbps!
  3. When I was using Win 10 like my brother before, everything was good
  4. Now I am using Ubuntu and when Ubuntu laptop is turned off or disconnected from Wi-Fi, the speed on other devices is cutted down from 16-20 mpbs to 0.8 mbps. When Ubuntu is turned on again or connected to Wi-Fi, the speed is backing up to normal (16-20 mbps). If you turn off win10-laptop, there is no problem with speed.

I've tried to use other router, but it was the same. What's the problem? WHY Ubuntu-laptop is impacting on router's wifi speed?

Update

enter image description here

Update 2:

  1. Ubuntu's Wi-Fi is on

  2. Ubuntu's Wi-Fi is off enter image description here

Update 3 for David:

########## wireless info START ##########

Report from: 19 May 2016 14:38 SAMT +0400

Booted last: 19 May 2016 13:09 SAMT +0400

Script from: 27 Sep 2015 00:34 UTC +0000

##### release ###########################

Distributor ID: Ubuntu
Description:    Ubuntu 14.04.4 LTS
Release:    14.04
Codename:   trusty

##### kernel ############################

Linux 3.13.0-86-generic #131-Ubuntu SMP Thu May 12 23:33:13 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Parameters: ro, quiet, splash, vt.handoff=7

##### desktop ###########################

Ubuntu

##### lspci #############################

03:00.0 Network controller [0280]: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
    Subsystem: AzureWave AW-NE785 / AW-NE785H 802.11bgn Wireless Full or Half-size Mini PCIe Card [1a3b:1089]
    Kernel driver in use: ath9k

05:00.5 Ethernet controller [0200]: JMicron Technology Corp. JMC250 PCI Express Gigabit Ethernet Controller [197b:0250] (rev 03)
    Subsystem: ASUSTeK Computer Inc. Device [1043:1905]
    Kernel driver in use: jme

##### lsusb #############################

Bus 002 Device 003: ID 25a7:2433  
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 13d3:5130 IMC Networks Integrated Webcam
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

##### PCMCIA card info ##################

##### rfkill ############################

0: asus-wwan: Wireless WAN
    Soft blocked: no
    Hard blocked: no
1: asus-wimax: WiMAX
    Soft blocked: no
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

##### lsmod #############################

ath9k                 164164  0 
ath9k_common           13551  1 ath9k
ath9k_hw              453856  2 ath9k_common,ath9k
ath                    28698  3 ath9k_common,ath9k,ath9k_hw
mac80211              638915  1 ath9k
cfg80211              496328  3 ath,ath9k,mac80211

##### interfaces ########################

auto lo
iface lo inet loopback

##### ifconfig ##########################

eth0      Link encap:Ethernet  HWaddr <MAC 'eth0' [IF]>  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:50 

wlan0     Link encap:Ethernet  HWaddr <MAC 'wlan0' [IF]>  
          inet addr:192.168.0.65  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::<IP6 'wlan0' [IF]>/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:248779 errors:0 dropped:0 overruns:0 frame:0
          TX packets:156344 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:346924202 (346.9 MB)  TX bytes:14768748 (14.7 MB)

##### iwconfig ##########################

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"UM-225"  
          Mode:Managed  Frequency:2.472 GHz  Access Point: <MAC 'UM-225' [AC1]>   
          Bit Rate=58.5 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-40 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:57   Missed beacon:0

##### route #############################

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 wlan0
192.168.0.0     0.0.0.0         255.255.255.0   U     9      0        0 wlan0

##### resolv.conf #######################

nameserver 127.0.1.1
search Dlink

##### network managers ##################

Installed:

    NetworkManager

Running:

root       825     1  0 13:09 ?        00:00:03 NetworkManager

##### NetworkManager info ###############

NetworkManager Tool

State: connected (global)

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            jme
  State:             unavailable
  Default:           no
  HW Address:        <MAC 'eth0' [IF]>

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off

- Device: wlan0  [UM-225 1] ----------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ath9k
  State:             connected
  Default:           yes
  HW Address:        <MAC 'wlan0' [IF]>

  Capabilities:
    Speed:           58 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    Explay:          Infra, <MAC 'Explay' [AC13]>, Freq 2457 MHz, Rate 54 Mb/s, Strength 54 WPA
    ASUS:            Infra, <MAC 'ASUS' [AN2]>, Freq 2437 MHz, Rate 54 Mb/s, Strength 62 WPA2
    325:             Infra, <MAC '325' [AC10]>, Freq 2437 MHz, Rate 54 Mb/s, Strength 49 WPA WPA2
    wtrende:         Infra, <MAC 'wtrende' [AC4]>, Freq 2412 MHz, Rate 54 Mb/s, Strength 49 WPA WPA2
    Ultramarin_230:  Infra, <MAC 'Ultramarin_230' [AC8]>, Freq 2472 MHz, Rate 54 Mb/s, Strength 39 WPA2
    Genius:          Infra, <MAC 'Genius' [AN6]>, Freq 2417 MHz, Rate 54 Mb/s, Strength 45 WPA2
    TP-LINK_327:     Infra, <MAC 'TP-LINK_327' [AC3]>, Freq 2412 MHz, Rate 54 Mb/s, Strength 39 WPA WPA2
    TP-LINK222:      Infra, <MAC 'TP-LINK222' [AC9]>, Freq 2437 MHz, Rate 54 Mb/s, Strength 62 WPA WPA2
    nastya:          Infra, <MAC 'nastya' [AC6]>, Freq 2472 MHz, Rate 54 Mb/s, Strength 75 WPA2
    DIR-429:         Infra, <MAC 'DIR-429' [AC7]>, Freq 2472 MHz, Rate 54 Mb/s, Strength 29 WPA2
    TTK:             Infra, <MAC 'TTK' [AN11]>, Freq 2437 MHz, Rate 54 Mb/s, Strength 29 WPA WPA2
    TAM HET I/IHTEPHETA: Infra, <MAC 'TAM HET I/IHTEPHETA' [AC15]>, Freq 2462 MHz, Rate 54 Mb/s, Strength 39 WPA WPA2
    115:             Infra, <MAC '115' [AC14]>, Freq 2462 MHz, Rate 54 Mb/s, Strength 42 WPA WPA2
    TTK-427:         Infra, <MAC 'TTK-427' [AC12]>, Freq 2457 MHz, Rate 54 Mb/s, Strength 42 WPA WPA2
    TTK-211:         Infra, <MAC 'TTK-211' [AN15]>, Freq 2462 MHz, Rate 54 Mb/s, Strength 25 WPA WPA2
    ustu:            Infra, <MAC 'ustu' [AN16]>, Freq 2412 MHz, Rate 54 Mb/s, Strength 32 WPA WPA2 Enterprise
    TTK-423:         Infra, <MAC 'TTK-423' [AN17]>, Freq 2412 MHz, Rate 54 Mb/s, Strength 47 WPA WPA2
    TP-LINK-525:     Infra, <MAC 'TP-LINK-525' [AC11]>, Freq 2437 MHz, Rate 54 Mb/s, Strength 22 WPA WPA2
    ustu_open:       Infra, <MAC 'ustu_open' [AN19]>, Freq 2412 MHz, Rate 54 Mb/s, Strength 37
    Vlaf777:         Infra, <MAC 'Vlaf777' [AN20]>, Freq 2437 MHz, Rate 54 Mb/s, Strength 27 WPA2
    Phenomen:        Infra, <MAC 'Phenomen' [AC5]>, Freq 2437 MHz, Rate 54 Mb/s, Strength 52 WPA2
    Suck my dick per wi-fi: Infra, <MAC 'Suck my dick per wi-fi' [AN22]>, Freq 2452 MHz, Rate 54 Mb/s, Strength 15 WPA2
    TTK-207:         Infra, <MAC 'TTK-207' [AN23]>, Freq 2462 MHz, Rate 54 Mb/s, Strength 32 WPA2
    RTRouter-036281: Infra, <MAC 'RTRouter-036281' [AN24]>, Freq 2417 MHz, Rate 54 Mb/s, Strength 34 WPA2
    RTRouter-014050: Infra, <MAC 'RTRouter-014050' [AN25]>, Freq 2457 MHz, Rate 54 Mb/s, Strength 24 WPA2
    *UM-225:         Infra, <MAC 'UM-225' [AC1]>, Freq 2472 MHz, Rate 54 Mb/s, Strength 79 WPA2
    Angry_Kot:       Infra, <MAC 'Angry_Kot' [AN27]>, Freq 2437 MHz, Rate 54 Mb/s, Strength 30 WPA WPA2
    Rostelecom231:   Infra, <MAC 'Rostelecom231' [AN28]>, Freq 2462 MHz, Rate 54 Mb/s, Strength 19 WPA WPA2
    ryxxx:           Infra, <MAC 'ryxxx' [AN29]>, Freq 2437 MHz, Rate 54 Mb/s, Strength 14 WPA2

  IPv4 Settings:
    Address:         192.168.0.65
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.0.1

    DNS:             192.168.0.1

##### NetworkManager.state ##############

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true

##### NetworkManager.conf ###############

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

no-auto-default=<MAC 'eth0' [IF]>,

[ifupdown]
managed=false

##### NetworkManager profiles ###########

[[/etc/NetworkManager/system-connections/UM-225 1]] (600 root)
[connection] id=UM-225 1 | type=802-11-wireless
[802-11-wireless] ssid=UM-225 | mac-address=<MAC 'wlan0' [IF]>
[ipv4] method=auto
[ipv6] method=ignore

[[/etc/NetworkManager/system-connections/TSARYOV]] (600 root)
[connection] id=TSARYOV | type=802-11-wireless
[802-11-wireless] ssid=TSARYOV | mac-address=<MAC 'wlan0' [IF]>
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/Beeline_WiFi_FREE]] (600 root)
[connection] id=Beeline_WiFi_FREE | type=802-11-wireless
[802-11-wireless] ssid=Beeline_WiFi_FREE | mac-address=<MAC 'wlan0' [IF]>
[ipv6] method=auto
[ipv4] method=auto

[[/etc/NetworkManager/system-connections/Rostelecom231]] (600 root)
[connection] id=Rostelecom231 | type=802-11-wireless
[802-11-wireless] ssid=Rostelecom231 | mac-address=<MAC 'wlan0' [IF]>
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/DIR-429]] (600 root)
[connection] id=DIR-429 | type=802-11-wireless
[802-11-wireless] ssid=DIR-429 | mac-address=<MAC 'wlan0' [IF]>
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/UM-225]] (600 root)
[connection] id=UM-225 | type=802-11-wireless
[802-11-wireless] ssid=UM-225 | mac-address=<MAC 'wlan0' [IF]>
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/ustu_open]] (600 root)
[connection] id=ustu_open | type=802-11-wireless
[802-11-wireless] ssid=ustu_open | mac-address=<MAC 'wlan0' [IF]>
[ipv6] method=auto
[ipv4] method=auto

[[/etc/NetworkManager/system-connections/DIR-300]] (600 root)
[connection] id=DIR-300 | type=802-11-wireless
[802-11-wireless] ssid=DIR-300 | mac-address=<MAC 'wlan0' [IF]>
[ipv4] method=auto
[ipv6] method=auto

##### iw reg get ########################

Region: Europe/Samara (based on set time zone)

country 00:
    (2402 - 2472 @ 40), (3, 20)
    (2457 - 2482 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
    (2474 - 2494 @ 20), (3, 20), NO-OFDM, PASSIVE-SCAN, NO-IBSS
    (5170 - 5250 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
    (5735 - 5835 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS

##### iwlist channels ###################

eth0      no frequency information.

lo        no frequency information.

wlan0     13 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Channel 12 : 2.467 GHz
          Channel 13 : 2.472 GHz
          Current Frequency:2.472 GHz (Channel 13)

##### iwlist scan #######################

eth0      Interface doesn't support scanning.

lo        Interface doesn't support scanning.

Channel occupancy:

      4   APs on   Frequency:2.412 GHz (Channel 1)
      3   APs on   Frequency:2.437 GHz (Channel 6)
      2   APs on   Frequency:2.457 GHz (Channel 10)
      2   APs on   Frequency:2.462 GHz (Channel 11)
      4   APs on   Frequency:2.472 GHz (Channel 13)

wlan0     Scan completed :
          Cell 01 - Address: <MAC 'UM-225' [AC1]>
                    Channel:13
                    Frequency:2.472 GHz (Channel 13)
                    Quality=68/70  Signal level=-42 dBm  
                    Encryption key:on
                    ESSID:"UM-225"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000000d16efc86f
                    Extra: Last beacon: 48ms ago
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
          Cell 02 - Address: <MAC '

Update: Router is DLink DIR-300

SOLUTION
Well, the problem, apparently, is to configure the wireless mode. It was installed B/G/N mixed. If you set the G mode, the problem does not occur.

B/G/N mixed - the speed is normal, but the problem remains.

B - the speed is always low.

G - the speed is always normal, there is no problem with Ubuntu.

N - the speed is normal, but the problem remains.

12
  • Maybe check that Ubuntu isn't running some DHCP server (ps -ef | grep -i dhcp, ignore dhcp-client, but anything else might be suspicious). Check the ip address of each, make sure they are all unique (but the same first 3 parts, e.g., 192.168.1.xxx). Try starting from scratch: turn off all devices, then boot in order: modem (if any), router, iphone & windows... and see how they perform, check ip addresses again. Then start ubuntu and see if performance is different... Last, disable any proprietary wireless driver that ubuntu might be using, and see if that changes anything. (Just guessing...) – michael May 17 '16 at 9:49
  • @michael_n I've updated question 1. I have no proprietary wireless driver 2. I've made sure, that IP address of each device is unique – Gikas May 17 '16 at 13:43
  • So should the title of your question be "Ubuntu improves speed to other devices"? Because you say when Ubuntu is running, the other devices work well. – Organic Marble May 17 '16 at 14:09
  • @OrganicMarble It's not correct. After running other devices without running ubuntu-notebook or just after router rebooting speed is normal (16-20 mbps) – Gikas May 17 '16 at 14:37
  • 2
    Well, you say". When Ubuntu is turned off or disconnected from Wi-Fi, the speed on other devices is cutting down to 0.8 mbps" so I'm confused as to what your actual problem is. – Organic Marble May 17 '16 at 15:11
1
+50

Just so that we are clear on this, some points:

  1. The Ubuntu laptop was previously running Windows
  2. The speed of the network goes up when you have Ubuntu in the mix. Take out the Ubuntu laptop and the speed goes down.

What I would check:

  1. The model of the router (update your question please).
  2. Whether there exists any address reservation. I have seen that in some routers, if there is a reservation for a card that advertises as, say, 11g, that is the maximum for all other devices (a.k.a mixed mode). In this case, what might be happening (just a guess) is that the router has knowledge of MAC x.x.x.x.x.x at 11g, but when it actually comes online, it reports as n, so the router raises the speed because now all active devices are at n speed. When it goes offline, the router falls back to its saved values.
  3. Look for a setting on the router that forces it to the maximum possible speed (G/N/whatever) and see if that helps.
  4. If nothing else works, then have you tried reconfiguring the router?

Again, it might be helpful if you posted the model of the router.

2
  • Well, the problem, apparently, is to configure the wireless mode. It was installed B/G/N mixed. If you set the G mode, the problem does not occur. B/G/N mixed - the speed is normal, but the problem remains. B - the speed is always low. G - the speed is always normal, there is no problem with Ubuntu. N - the speed is normal, but the problem remains. Thanks for the help. But still would like to know why in B/G/N mixed is this happening? – Gikas May 20 '16 at 9:41
  • 1
    Glad that you now have at least narrowed it down to the router ! I think that - short of doing all sorts of reconfiguration ju jitsu - the next step would be to reset the router to defaults and go from there. Not saying that the ju jitsu approach is bad per se, but you might save some time by just resetting the router. – Hopping Bunny May 23 '16 at 8:27
1

The reason this is happening and it wasn't with Windows is because in Windows you have to enable 802.11n mode manually, in Ubuntu it will automatically enable it on the connection if it is auto negotiated with the router. If it autonegotiates an N connection this will have an impact on other connections in a mixed environment. 802.11n - Wikipedia

This is why you are not seeing the issue when you have the router set to G.

You can follow the guide below for more information, to test it quickly though and see if it is the issue at hand you can disable 802.11n on Ubuntu, reboot your router, then reboot and or shutdown Ubuntu to see if it still interferes with the other connections.

sudo sh -c 'modprobe -r iwlwifi && modprobe iwlwifi 11n_disable=1'

Turn off 802.11n permanently

The other option is if your Windows/other devices support N you could enable it on those devices and set the router to N so that they are all on the same bands without the backward compatibility issues.

0

I saw a thread on another forum recently with the same problem. Person had one or more device's ethernet plugged into a surge protector. Removing the surge protector from the chain solved the problem for him/her.

1
  • If I understand correctly.. I tried to turn off the ubuntu-laptop from the network (work with battery) and then test. The problem, unfortunately, is not solving – Gikas May 19 '16 at 18:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.