0

This question already has an answer here:

I'm getting following error;

vp-bash: cannot create temp file for here-document: No space left on device


df -h Filesystem Size Used Avail Use% Mounted on /dev/root 3.6G 3.5G 0 100% / devtmpfs 459M 0 459M 0% /dev tmpfs 463M 0 463M 0% /dev/shm tmpfs 463M 6.3M 457M 2% /run tmpfs 5.0M 4.0K 5.0M 1% /run/lock tmpfs 463M 0 463M 0% /sys/fs/cgroup /dev/mmcblk0p1 60M 20M 41M 34% /boot tmpfs 93M 0 93M 0% /run/user/1000

What would be the best way to increase the size of /tmp?

When i try to umount it, I'm getting following error; umount: /tmp: not mounted

marked as duplicate by Sergiy Kolodyazhnyy, Pilot6, Community May 15 '16 at 10:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

You root partition is full (Mounted on /). Since /tmp is a directory on / you have (at least) two options:

a) Increase size of /. You may do this for example with the GParted live disk: http://gparted.org/livecd.php

b) Mount another partition on /tmp. For this you need to add an entry to your /etc/fstab file like this:

/dev/sdb1 /tmp               ext4    errors=remount-ro 0       0

Replace /dev/sdb1 with a partition you prepared before. You can use the GParted live disk again for preparing the partition.

I suggest you doing a) because otherwise your root partition is full and the system may stop working. b) helps if you have much stuff stored in /tmp.

Hope this helps.

Not the answer you're looking for? Browse other questions tagged or ask your own question.