1

This question already has an answer here:

I was poking through the settings in unity tweak tool, adjusted a few things just to see what they did. Like window behavior on sides/corners multi desktops (forgot what they are called in ubuntu)

The very last thing I touched was the reset button and it broke it. My top bar is now gone, the launcher is gone, and the super key wont start a search. I have tried a ton of things I've read to fix it without luck, will list what I have tried.

tried reseting unity "unity-tweak-tool --reset-unity" it asks me to log out and back in which I am not sure how to do via terminal as I have no top bar to do the normal way. I logged out by using sudo service lightdm reset but I dont know if that is correct, it got me back to the login screen but upon log in everythings the same.

I tried running unity via terminal and get: unity-panel-service stop/waiting unity7 stop/waiting unity-panel-service start/running, process 3102 unity7 start/running, process 3104

those numbers change sometimes but it never works, screen flashes a bit, some windows come and go but then in the end nothing stays.

I went to restore from back in time but through terminal it says its not configured which i dont understand because I had it doing daily backups with back in time root. Which I watched it do the first one but now cannot find.

Any help is appreciated.

marked as duplicate by Sergiy Kolodyazhnyy, Community May 15 '16 at 16:37

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Do you have a startup usb? – Jacob Vlijm May 15 '16 at 5:19
  • Ideally what you'd need to have is CompizConfig Settings Manager . Unity in and of itself is just a plugin to compiz. Sometimes ( for whatever reason ) those plugins get unset (reset button could have done that) , and one looses launcher and panel , which are really just plugins to compiz. I've broken my Unity multiple times, and each time all that was needed to do is to reenable Unity plugin and a few others , like Desktop Wall and Viewport Switcher – Sergiy Kolodyazhnyy May 15 '16 at 6:21
  • Thank you, that worked. It hung on enabling unity and when I eventually gave up and closed everything unity came back up. – Ryodan May 15 '16 at 16:42
1

I'm assuming you can access the internet. This solved it when it happened to me.

Type the following on a terminal. (Right click on the desktop to open one)

sudo apt-get install dconf
sudo dconf reset -f /org/compiz/ 
setsid unity
unity --reset-icons
  • Gave that a shot, it does flashes all the windows on screen a few times and nothing.says the following:unity-panel-service stop/waiting unity7 stop/waiting unity-panel-service start/running, process 3113 unity7 start/running, process 3265 – Ryodan May 15 '16 at 16:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.