5

I have a laptop hooked up to a TV via HDMI. When the TV powers off, the audio output switches from HDMI to the built-in laptop speakers. This behaviour is new, as previous Ubuntu versions would always stay on the last device I chose (HDMI.) How can I control this feature so as to always have HDMI selected even when the TV is off?

Failing that, how can I disable the built-in laptop speakers so they are never available, hopefully forcing the audio output to HDMI?

3

So it turns out everything you think you're editing in /etc/pulse/default.pa file isn't doing squat until you copy it to your current user profile (~/.config/pulse/) Shout out to Nebuzaradan for discovering the solution: https://unix.stackexchange.com/questions/293399/how-to-set-hdmi-sound-output-as-default-on-ubuntu-16-04

0

You can use pavucontrol (Pulseaudio volume control, install if necessary):

Launch it from multimedia menu, go to the "output devices" tab, and click the green "define as alternative" button that is near HDMI soundcard.

Look also "configuration" tab: you will find various profile such as HDMI .

  • Hi laugeo, the option you're referring to was "define as fallback device" and was already selected for my HDMI and built-in speakers. I de-selected the option for the built-in speakers, but it made no difference after power cycling my TV. Thanks for the idea though. – Cacklson May 17 '16 at 2:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.