23

I'm trying to install utorrent program, and when I execute the program I get

./utserver: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory

I'm navigating the different forums since yesterday and I didn't find anything helpful till now, so please tell me what's the problem ??

  • Sorry to say but libssl0.9.8 is required by Comodo Antivirus and does not work under Ubuntu 16.04, which by the way has libssl1.0.0 installed on it. Why is it happening? – César Biosca Jul 16 '16 at 1:40
  • You can download 0.9.8 and then place it or a symlink inside your system folder. And then you can check with ldd <your bin> if it sees your libssl. – IgorZ Feb 27 '19 at 10:06
17

In general you should search for software through the software center or if you like the command line, you can use apt-cache search. In this case, the following package showed up (on 11.10): libssl0.9.8

You could try to install it (sudo apt-get install libssl0.9.8). If this does not help, you might want to tell us, which ubuntu version you are using.

| improve this answer | |
8

On Ubuntu 12.04 64bit version, it worked to install the 32 bit version:

sudo apt-get install libssl0.9.8:i386

But, of course, when you're on 32 bit Ubuntu, this should just work (without the :i386):

sudo apt-get install libssl0.9.8
| improve this answer | |
7

If you are using 11.10 (since you did not mention it) you then have libssl1.0.0 which is higher than 0.9.8. Any program that needs 0.9.8 will also be able to handle versions above that one.

If you do NOT have 11.10 then you have several ways:

  1. Go to the OpenSSL site: http://www.openssl.org/ and follow installations there.

  2. Go to Ubuntu Packages and download the .DEB from there: http://packages.ubuntu.com/

  3. Go to Debian Packages and dowload the .DEB from there: http://www.debian.org/distrib/packages

  4. Install it via apt-get or aptitude:

    • sudo apt-get install libssl0.9.8 - For 0.9.8 Version
    • sudo aptitude install libssl0.9.8 - For 0.9.8 Version
    • sudo apt-get install libssl1.0.0 - For 1.0.0 Version
    • sudo aptitude install libssl1.0.0 - For 1.0.0 Version
| improve this answer | |
  • I'm not sure about that you can apply 1.0.0 when you need 0.9.8 because api/headers are different. Compilation will fail if you replace them without any other changes in your code. – IgorZ Feb 27 '19 at 10:04
0

Just try this steps when you need it for CAV for Linux.

If you already tried to install cav but there is error with Libssl0.9.8:

  1. sudo apt-get --purge remove cav-linux
  2. Deinstall all libssl0.9.8 from/with Synaptic
  3. sudo apt-get clean
  4. sudo apt-get autoremove
  5. sudo aptitude install libssl0.9.8

and then install the normal way.

  1. Create a directory /opt/COMODO

    Copy cav file there:

    cd /opt/COMODO
    sudo dpkg -i cav-linux_1.1.268025-1_amd64.deb
    
  2. Download driver and rebuild driver

    copy them to /opt/COMODO

    run post setup:

    sudo /opt/COMODO/post_setup.sh
    
  3. Execute this only if you get an error that RedirFS modules are not installed

    sudo bash /opt/COMODO/fix_rebuild_driver.sh
    sudo /opt/COMODO/post_setup.sh
    
  4. Reboot

| improve this answer | |
0

Download package

http://archive.ubuntu.com/ubuntu/pool/universe/o/openssl098/libssl0.9.8_0.9.8o-7ubuntu3.1_i386.deb

Then install it

sudo apt install "libssl0.9.8_0.9.8o-7ubuntu3.1_i386.deb"
| improve this answer | |
  • Have you tried that yourself? Did it break your package system? – Simon Sudler Sep 7 '19 at 17:30
  • Yeah i have and it solved my problem. I have not see any side effects yet. – mustafa candan Sep 10 '19 at 18:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.