3

I have Ubuntu 16.04 with all restricteds, addons, libs, etc installed and regionset China. I can play most DVDs from various sources and regions. But I cannot play any DVD that has been burned in China locally: copies of foreign dvds can play, but China specific cannot. The o/s will not even see a Chinese dvd in the drive, and gives error no disk found. Obviously, I need a codec or library or whatever. Has anyone had this problem and have you solved it? Please share your knowledge. Where can I find the codecs, apps, libs, etc ? Thanks.

7
  • OK first of all , you need to check if you have two packages installed regionset and libdvdread4 . What does apt-cache policy libdvdread4 regionset tell you ? – Sergiy Kolodyazhnyy May 15 '16 at 1:38
  • OTHER USERS : the question asks about specific problem related to media playback on supported release of Ubuntu. DO NOT DOWNVOTE OR VOTE TO CLOSE THIS QUESTION – Sergiy Kolodyazhnyy May 15 '16 at 1:41
  • Hi Serg and thanks for reply. Yes, installed, and here is output... $ apt-cache policy libdvdread4 regionset libdvdread4: Installed: 5.0.3-1 Candidate: 5.0.3-1 Version table: *** 5.0.3-1 500 500 mirrors.aliyun.com/ubuntu xenial/universe amd64 Packages 100 /var/lib/dpkg/status regionset: Installed: 0.1-3 Candidate: 0.1-3 Version table: *** 0.1-3 500 500 mirrors.aliyun.com/ubuntu xenial/universe amd64 Packages 100 /var/lib/dpkg/status – rob grune May 15 '16 at 6:00
  • ok, you have both packages , from what i see. Typically dvd drive is designated as /dev/sr0 . What happens if you do sudo regionset /dev/sr0 ? – Sergiy Kolodyazhnyy May 15 '16 at 6:13
  • Thanks again for reply. 1/ For a readable dvd, regionset returns the number "6", which is correct for China. 2/ The dvd in question is not readable using Ubuntu. Regionset requires a readable dvd, and is thus useless in my case. – rob grune May 16 '16 at 1:15
2

I found the final solution by trial and error, after my laptop gave me clues (it has win7 and 15.10 loaded), and after weeks of frustrations without help. I loaded everything I could find for dvd: gxine; libxine-all; everything for ffmpeg; python3dvd; quicktime -lib and -util. I reinstalled the libdvd-read -css2 etc as a precaution. This enabled 16.04 to at least read the dvd and attempt to play it. VLC gave me an error reading about blocks, which is a cryptic way of stating the drive itself may be a problem. Seems my sata drive was too old and could not process the blocks. Bought a new drive and problem now solved. I hope my troubles and solution may benefit others. p.s. I think the quicktime is the main solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.