I think everyone has known - we need to install katoolin to use Kali Linux Tools on Ubuntu. Before did anything I had looked through the internet and also found out these solutions: Can I install Kali tools on Ubuntu, How to Auto Install All Kali Linux

So here are my steps:

apt-get install git
git clone https://github.com/LionSec/katoolin.git && cp katoolin/katoolin.py /usr/bin/katoolin
chmod +x  /usr/bin/katoolin
sudo katoolin

Then, to add Kali Linux repositories and update them, I selected option 1 from the katoolin Menu

Then, to view the available categories and install all available tools, I selected option 2 from the main menu of katoolin and then pressed 0.

But after that I got this:

unable to locate package webshag

What do you want to do ?>  

1) Add Kali repositories & Update 
2) View Categories
3) Install classicmenu indicator
4) Install Kali menu
5) Help

kat > 2

************************** All Categories **************************

1) Information Gathering                      8) Exploitation Tools
2) Vulnerability Analysis                     9) Forensics Tools
3) Wireless Attacks                           10) Stress Testing
4) Web Applications                           11) Password Attacks
5) Sniffing & Spoofing                        12) Reverse Engineering
6) Maintaining Access                         13) Hardware Hacking
7) Reporting Tools                            14) Extra

0) All

Select a category or press (0) to install all Kali linux tools .

Furthermore, I got an error in Software Updater - it didn't let me do anything. Ubuntu just hung up. I solved this problem by deleting kali linux repositories in katoolin and then in Software Updater.

Does anyone know how to install Kali Linux tools in Ubuntu 16.04 in a proper way?


4 Answers 4



Katoolin is a collection of scripts for automating the installation of Kali linux tools in different platforms other than Kali linux, and installing Kali linux tools with Katoolin in other OSs or Windows Subsystem for Linux is always less secure than installing the same tools in Kali Linux. Kali Linux is named after the Hindu goddess of destruction which should give the user some indication that even Kali Linux itself is risky and difficult to manage, especially for new users.

Katoolin draws its tools from a variety of sources including apt and GitHub. Katoolin doesn't know anything about the platform that it is running on, so the safest way to use Katoolin is to install each tool the hard way one tool at a time, checking each time to see if that tool is included in the default Ubuntu repositories and if so installing it that way instead. When the installation is finished, the software sources that were added by Katoolin should be immediately disabled in order to prevent Katoolin from replacing packages that were installed from the default Ubuntu repositories with its own updated packages whenever Ubuntu software is updated.

Installation of Kali linux tools

(Re)install Katoolin as follows:

  1. Open the terminal and type:

    sudo apt install git  
    git clone https://github.com/LionSec/katoolin.git && sudo cp katoolin/katoolin.py /usr/bin/katoolin  
  2. Make /usr/bin/katoolin executable.

    sudo chmod +x /usr/bin/katoolin  
  3. Run Katoolin as follows and you will see the Katoolin interface:

    cd /usr/bin/
    sudo ./katoolin   

    enter imageterminal an description here
    View the categories of available software in katoolin interface

Press 0 to install all Kali linux tools.

When you go to View Categories and then enter 0 for all, the installer will immediately return to where you were. Scroll up, and you'll see that a number of the packages can't be found. Those packages are no longer maintained or have been removed from the Kali repositories. Even with this issue, you'll still find a lot of the Kali software available for installation.

So the best option is to install Kali linux tools in a series of distinct steps. Just like if you want to install Forensic tools on your system, then choose its option from the category and then type 0 to install all forensics tools. If this still doesn't work, then you have to install whatever forensic tools that can be installed one package at a time.

This is why the Katoolin interface sometimes hangs when you try to install all of the Kali linux tools at once. Take the time of waiting for the server to respond to a request for a package that is not available and multiply it by how many unavailable Kali linux tools there are in the Katoolin repositories.

enter image description here

If you wish to go back to the main menu, type gohome in your katoolin interface. Now select the option 3 or 4 to install either the classicmenu indicator or the Kali menu. Press the y key to continue and then press Enter to start its setup.

Once you are done with installation of Kali tools using katoolin, you can quit by pressing the keyboard combination Ctrl+C and you will see the goodbye message.

shutdown requested....Goodbye...

Credit for the above text block goes to Kashif at How To Install Kali Linux Tools On Ubuntu 16 And CentOS 7 with my additions italicized.

Warning about updates after installing Kali linux tools

The LionSec Katoolin GitHub webpage clearly warns Katoolin users to be careful when updating software.

Before updating your system, please remove all Kali-linux repositories to avoid any kind of problem.

enter image description here

  • 1
    Thanks a lot for the answer. But it's not clear how can I install one package at a time in case it is not downloaded via katoolin. I need to install it separately - am I right?And how can I do this?
    – fuser
    Commented Sep 20, 2016 at 10:12
  • 2
    If you press 0 on the Forensic tools screen katoolin tries to install all 23 forensic tools, but you can also press 1 to install only forensic tool 1, 2 to install only forensic tool 2, etc. by a process of divide and conquer. There are 330 Kali linux tools, so it's more time consuming to do everything one package at a time, but it's also less destabilizing to your operating system. It seems to me that Katoolin is giving hints to help me think like a hacker like when I lose my money in a soft drink vending machine, I have to kick the vending machine to break it for everyone else.
    – karel
    Commented Sep 20, 2016 at 10:29
  • So I did the next steps: step1- sudo katoolin, step2- View Categories, step3 - сhoose 5-Sniffing & Spoofing, step4 - choose 20 and got the next kat > 20 Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package sipp . What should I do next? Install sipp package on my own in ubuntu and then relaunch katoolin and chose this option again?
    – fuser
    Commented Sep 20, 2016 at 12:33
  • I searched for sipp manually and found it at Ubuntu Packages Search. The sipp program is provided by the sip-tester package from the default Ubuntu repositories. To install it in Ubuntu type: sudo apt-get install sip-tester Then sipp will be installed to /usr/bin/sipp I also downloaded another file called sipp-1d6c5d8.tar.gz from elsewhere in case you want to install that.
    – karel
    Commented Sep 20, 2016 at 14:23
  • Dear karel, but if I repeat the steps mentioned in my question the issue will happen again. So it is very strange as for me to see such behavior of katoolin. The summary of all you described above lead to the following conclusion: 1) katoolin is not configured properly to interact with ubuntu 16.04 LTS 2) if someone wants to use katoolin on ubuntu 16.04 LTS he/she has to do it in a series of distinct steps 3)if some package is missing it is needed to install it on your own in case you can find that package. Do I understand this right?
    – fuser
    Commented Sep 22, 2016 at 5:12

After using katoolin and adding the repositories , its safe to run sudo apt-get update, but do not use apt-get upgrade if you do, your gnome and desktop will fail to start.

In katoolin :

  1. Add kali repositories & Update

  2. Update your apt-get by katoolin or your terminal

Install all the tools you want, after that do the cleaning by removing kali repos from your sources.list and apt-key.

If any error occurs, it comes from the sources.list, meaning the package or tool is not designed/available for your Linux architecture or katoolin itself has to be updated, because repositories were changed by the owner.


  1. Keep in touch with katoolin developers.

  2. Install aptitude:

    sudo apt-get install aptitude

    then do a search for the requirements of the package candidates, for example:

    aptitude search "?provides(wine)"

    read more about aptitude: What is the difference between dpkg and aptitude/apt-get?

  3. Read about the difference between unable to locate package & no candidates: What does Package <package> has no installation candidate mean?

There is a step by step solution that avoids crashes here: Can I install Kali tools on Ubuntu?


In Ubuntu 16: edit file /usr/bin/katoolin and remove all references for the both packages: dff and webshag and save file.

Execute katoolin again - choose 1 and then 2 to update - after that type back and choose 2 and then type 0.

For me it still showed an error for usb-modeswitch for version 2.2.5+repack0-1ubuntu1, so I installed using this package from ubuntuupdates.org

After that I executed katoolin again - chose 1 and then 2 to update - after that type back and choose 2 and then 0 to begin installation.

  • Could you, please, clarify what those references exactly are? In the previous answer was the same like proposition, but it did not work.
    – fuser
    Commented Jul 4, 2016 at 18:19

I have faced the very same
Edit the file /usr/bin/katoolin (eg use sudo -H gedit usr/bin/katoolin) and remove those two packages, just search for text dff and webshag. Remove those two from apt-get commands too.

  • Well, I did what you said, but this didn't work for me. Maybe some specific option or maybe more explanation from you can resolve the problem.
    – fuser
    Commented May 25, 2016 at 19:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .