3

I've just upgraded to 16.04, and tried to download brightness controller from Ubuntu Software, but I can't find it. I need to reduce the brightness for my eyes' health. Thanks. I'm using a desktop pc with Nvidia GT 220 graphics.

3

Until you find a better way, you should be able to set the brightness by editing /etc/sysfs.conf

Have a look in /sys/class/backlight to see what is there. I have (a symlink) intel_backlight but it could be radeon_b10 or something else depending on your hardware. In any case, inside it you should find a file called brightness which contains only a number that represents the current brightness. Make a note of the number! To change this value first make sure you have this package:

sudo apt install sysfsutils

then open the conf file with a text editor

sudo nano /etc/sysfs.conf

at the end of the file add a line like this:

class/backlight/intel_backlight/brightness = 4000

replace the path with the path to your brightness file (starting with class and no /), and replace 4000 with whatever number you think the brightness should be - my max brightness is 7812, so 4000 would make it about half as bright. Save the file and exit, then reboot. You will have to use trial and error to find the right brightness this way.

Here's where I learned how to do this

  • I've installed xbacklight but it doesn't change the brightness when pushing those commands... Thanks the same. – Roque May 14 '16 at 23:48
  • Aww that's annoying. I changed my answer to a different workaround - try this one instead – Zanna May 15 '16 at 6:50
0

Pre Ubuntu LTS 16.04

Under (X)Ubuntu 14.04 LTS, brightness control on my Panasonic Toughbook CF-52 used to work fine by adding acpi_osi=Linux to the GRUB_CMDLINE_LINUX_DEFAULT= line in /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

and issuing

$ sudo update-grub

after editing and before rebooting.

Since Ubuntu LTS 16.04

However, above solution stopped working after upgrading to (X)Ubuntu LTS 16.04. This appears to be typical for laptops with integrated Intel video graphics.

One can check this with the following command:

$ ls /sys/class/backlight/
    intel_backlight  panasonic

At least intel_backlight should be mentioned, most probably in addition to an OEM name like for example panasonic, dell_backlight, etc.

If this is the case, proceed with creating the following file

$ sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf

with contents:

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"
EndSection

Reboot, and enjoy your backlight buttons!

Source

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.