On Ubuntu 16.04 LTS with a 500GB external WD Hard Drive.

After formatting to NTFS, I can not write files using the graphical Files explorer, I get the pop up error seen below:

Pop up error copying files:


I've tried the following:

$ sudo apt-get purge ntfs-3g
$ sudo apt-get install ntfs-3g

This reinstalled the ntfs-3g tools. Great, but I still can't do anything. Here's the out put of ls -al /media, sudo fdisk -l and cat /etc/fstab

$ ls -al /media

drwxrwxrwx   1 kf   kf   4096 May 14 14:09 ntfs

$ sudo fdisk -l 

Disk /dev/sdc: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: FB6876F3-56D8-49CD-B0BB-55B07240A75B

Device      Start       End   Sectors   Size Type
/dev/sdc1      40    409639    409600   200M EFI System
/dev/sdc2  411648 976773134 976361487 465.6G Microsoft basic data

$ cat /etc/fstab

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name  devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/ubuntu--vg-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda2 during installation
UUID=08fdc860-fb67-4527-bf63-5114d08f16f4 /boot           ext2    defaults        0       2
# /boot/efi was on /dev/sda1 during installation
UUID=8CA6-E334  /boot/efi       vfat    umask=0077      0       1
#/dev/mapper/ubuntu--vg-swap_1 none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0
/dev/sdc2 /media/ntfs ntfs-3g locale=en_US.UTF-8,permissions 0 0

I've gone through all the other posts here on AskUbuntu about this issue, but nothing has helped. Where do I go next?

  • So at this point, I've just done sudo cp Documents/ /media/kf/<UUID>/ and it's copying the files over. Will I be able to recover these files later?
    – kfrz
    May 14, 2016 at 21:59

3 Answers 3


I believe you have to remount the partition/disk in read/write mode. I had same problems with one of newly created partitions. Try

sudo mount -o remount,rw /PartitionID /MountPoint

Enter the right PartitionID and MountPoint.

  • I tried sudo mount -o remount,rw /dev/sdc2 /media/ntfs and it did not work.
    – kfrz
    May 14, 2016 at 20:04
  • Try reading this post askubuntu.com/questions/333287/external-hard-disk-read-only May 14, 2016 at 20:20
  • I follow through that post (again). Remounting with sudo umount /dev/sdc2 and sudo mount -o rw,uid=1000,gid=1000,user,exec,umask=003,blksize=4096 /dev/sdc2 /media/ntfs results in permissions of drwxrwxr-- 1 kf kf 4096 May 14 14:09 ntfs
    – kfrz
    May 14, 2016 at 20:27
  • And I still can't write to the drive.
    – kfrz
    May 14, 2016 at 20:28
  • Is it possible that there is some switch on external disk that "locks" it in read mode? Like in SD cards. May 14, 2016 at 20:30

After a lot of attempt I solved the issue this way:

sudo mount -o remount,rw /PartitionID /MountPoint

you can find the partitionID with command sudo fdisk -l. The id looks like some random number. And MountPoint is the location of your drive. Usually resides in /media/user_name/. Even if after that you can't write, you might need to change the permission of writing using chmod sudo chmod u+w myfolder.

  • 1
    I couldn't solve from the accepted answer. I had to read the comments for how to know the Partition ID's. So I thought someone might find it helpful if I put this together. I had quite a hassle to find the solution Mar 22, 2020 at 6:43

I had the same issue, I fixed it with:

ntfsfix /dev/sdb1

Replace sdb1 with your partition's ID.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.