0

I have a client who I had to switch to Ubuntu after another Linux distro stopped working for her. I got her working on Ubuntu 14.04 as her laptop is older. All works fine - except for printing.

She has a Brother MFC-J825DW printer that worked fine with her old Linux (Puppy). But I cannot get the $#@! thing to work with Ubuntu!

I searched for instructions, and followed them (I think) correctly, but it didn't work. Here are the steps I took:

  • With both the computer and printer turned on, I plugged the USB cord from the printer into the computer.

  • When I did the above I did not get an option to select the model of the printer. Instead, I got the option to Enter URL - obviously wrong, as this is a USB connection. The >only< other option I got was Network Printer - also wrong for the same reason. No third option for USB was visible.

I also tried 2 different USB cords - but no change.

I've played a bit with Ubuntu, but could really use some advice from more experienced users.

0

Some Brother printers require a little more work than most other printers. Brother has been good about providing installation tools that usually work well. I believe this is the page you will need.

You have to run the downloaded tool as sudo. Unfortunately I am not near any of my Ubuntu systems at the moment and cannot tell you what other prompts you may need to answer, but I am sure you will need to enter your printer model.

  • can you update this at all? – Zanna Jul 24 '18 at 18:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.