I'm installing Ubuntu 16.04 on VirtualBox 5.0.20 at Windows 10 and I had a resolution issues which was solved by pressing Host Key + F1 and Host Key + F7. After it I tried to install and configure Google Chrome but it had some black artifacts, so I tried to play with 3D Acceleration at VB and now on boot I only see jumping black screen from one resolution to other and back. Pressing Host key for this case isn't working.

  • The same here, not only with google chrome but with at least gitkraken and VS code. – zerkms May 16 '16 at 11:15
  • And what is worse - downgrading to 5.0.18 did not help. It ruined my development VM, jeez. – zerkms May 16 '16 at 11:33
  • @zerkms any ideas how to resolve? – Viacheslav Kondratiuk May 16 '16 at 13:06
  • I disabled 3d and it worked for me (but presumably the whole OS now slower). I think that downgrading back to v5.0.18 + reinstalling kernel would help, but I haven't tried that yet. – zerkms May 16 '16 at 21:42

I also had problems with Ubuntu 16.04 in VirtualBox 5.0.20. My problems was with Chromium not rendering at all.

I then installed the Guest Additions 5.0.16 from the Download page and it solved my problems. https://www.virtualbox.org/wiki/Downloads

I just installed this Guest Addition on top of the current one.

| improve this answer | |
  • 1
    Yep, I can confirm that just installing older guest additions solved the problem. – zerkms May 28 '16 at 6:21
  • 1
    I can confirm on vbox 5.0.26 r108824 and Ubuntu 16.04.1 - 64bit – kommradHomer Jul 23 '16 at 21:37
  • 2
    This also worked for vbox 5.1.2 and Ubuntu 16.04 64-bit – Pakman Aug 18 '16 at 4:10
  • 5
    Hey future searchers - you can download the Guest Additions ISO here, named VBoxGuestAdditions_5.0.16.iso – Mendhak Sep 8 '16 at 8:55
  • Can confirm this also works for vbox 5.1.20 and Ubuntu 16.04.2 64bit. Just install the VBoxGuestAddtions_5.0.16.iso and it made my Atom IDE work again. No need to restart too. – majidarif Apr 23 '17 at 9:15

I had the same issue with 3D option on VBox 5.1.10 and Ubuntu 16.

To fix this on my side :

  1. Stop the VM
  2. Be sure you have 3D enabled/checked
  3. Start the VM and sudo as root
  4. Reinstall the VBox additions as root

Seems that the VBox additions are built based on the options already enabled ! So if you installed them without 3D options and then enable it, they are not supported correctly. At least it's an assumption based on what I observed. But after few days of bad experience, it's working perfectly for me.

| improve this answer | |
  • Did not work for me. – Hassan Apr 9 '17 at 8:39
  • Worked for me +1, I only needed steps 1. and 2. – hello_there_andy Nov 18 '17 at 22:34

I had already installed Guest Additions 5.0.16 when I got this problem, but turning off (unchecking) "Enable 3D Acceleration" in Machine...Settings...Display (Screen tab) did the trick for me. (Vbox Version 5.0.26 r108824)

| improve this answer | |
  • 3
    Turning off 3D acceleration will make the unity run very slow. – Hassan Aug 21 '16 at 7:59

Running Chrome with --use-gl=angle does the trick for me and I don't have to turn off the 3D acceleration. The command looks like this:

google-chrome --use-gl=angle

However for the normal usage I've modified every exec line in /usr/share/applications/google-chrome.desktop and added the mentioned param, so it looks like this (notice there are three occurences of exec):

Exec=/usr/bin/google-chrome-stable %U --use-gl=angle

Works in Ubuntu 16.10, VirtualBox 5.1.12

Also worth noting, that the only popular distro I've tried out that doesn't have this error in VirtualBox is Mint Mate 18.1. It works with 3D acceleration without any problems (so system screenshots are working as well).

| improve this answer | |
  • This seems to work fine. Can you explain what --use-gl=angle does compared to (not using) 3D acceleration? – Jey DWork Feb 10 '17 at 8:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.