My networking was working fine yesterday. I shut down, went to bed, and when I booted up this morning it won't even talk to the router; network-manager crashes.

I was wondering how to upgrade packages when it can't connect to the internet. My Ubuntu 15.10 laptop (this machine) connects to the internet through the same router just fine. Some of the error report:


NetworkManager crashed with SIGSEGV in nm_netlink_monitor_attach()

Unreportable reason

  You have some obsolete package versions installed.
  Please upgrade the following packages and check if the problem still occurs:

  network-manager, libnm-glib-vpn1, libnm-glib4, libnm-util2, network-manager
  • That's why this happened: bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1540088 and bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1540014 Faced the same problem yesterday.
    – Klaus
    May 14, 2016 at 14:12
  • 3
    related?: askubuntu.com/questions/771627/… ; Since there's already working solution, I won't copy my own from that question, but linking it may be helpful for someone. May 14, 2016 at 21:06
  • This is a big problem and it has affected elementary OS too(look at elementary OS StackExchange, it is filled with this)
    – Suici Doga
    May 15, 2016 at 3:09
  • If it is affecting multiple applications seemingly randomly, you may actually have bad RAM memory stick - if the problem doesn't happen reliably and with reproducible steps to find the problem, you may want to pull ram sticks (with computer turned off) until you find the one that has errors and causes crashes.
    – NoBugs
    May 15, 2016 at 8:49
  • Had the same issue in ubuntu 14.04. Accepted answer solved it (eth1 instead of eth0)!
    – user544977
    May 17, 2016 at 6:33

3 Answers 3


I had the same problem today. I had to setup the connection manually via command line to get to the internet and then I upgraded Ubuntu. After the upgrade it works fine. If you have DHCP on your router and using the cable, just type the following two commands:

sudo ifconfig eth0 up
sudo dhclient

It helped me to connect to the inernet and to update Ubuntu. After the update it works as yesterday. I have no idea why this happened.

I am not sure how to do it if you use WiFi. I am not sure replacing eth0 with wlan0 will work. If you use WiFi password protection, the procedure to connect via command line is more complicated. Some pointers in this case: https://unix.stackexchange.com/questions/92799/connecting-to-wifi-network-through-command-line, https://unix.stackexchange.com/questions/90778/how-to-bring-up-a-wi-fi-interface-from-a-command-line

You can also try to download packages to another computer and transfer them to your laptop and install them there. Here are the instructions how to install updates without internet connection: https://help.ubuntu.com/community/InstallingSoftware#Installing_packages_without_an_Internet_connection

  • Thank you so much. That seems to have worked. If you don't mind me asking, how do you learn these things? I'd like to get into it but there's so much to learn it's hard to know where to start.
    – CrazyApe84
    May 14, 2016 at 14:10
  • I am glad it helped. I administer Linux servers for 20 years and I use only Linux for my desktop for 5 years. The only thing you need is time and some will to learn. Don't you think that I did that solution just like that. I Googled the solutions on the internet. Some of the things I did in the past already (offline updates), so I knew what to look for. That's all. No magic.
    – nobody
    May 15, 2016 at 7:04
  • In your solution you say that you "upgraded Ubuntu". Are you talking about an upgrade from an older version of Ubuntu to a new version, or simply a package upgrade? I'm affected by this problem on Xubuntu 14.04, and wondering what I should attempt once I connect to the LAN cable.
    – gammapoint
    May 15, 2016 at 14:43
  • 1
    @gammapoint Just a simple package upgrade is enough.
    – nobody
    May 15, 2016 at 14:53
  • Thank you. This problem surfaced for me the weekend of 5/14/16 on Xubuntu 14.04. Following nobody's advice and doing a simple package update fixed the issue and everything is working as expected.
    – gammapoint
    May 15, 2016 at 17:39

The solution proposed by 'nobody' hasn't worked for me as my computer was unable to connect via ethernet and "sudo dhclient" didn't give any output.

This worked for me: Solution if you're unable to connect via ethernet.

The step 2 proposed by 'r2rien' worked as a charm and it is really simple, just download the three files (libnl, libnl-genl, libnl-route) in an online computer, put them in a USB stick and install them in the offline Linux via:

sudo dpkg -i libnl-*.deb

then you just have to restart the service with:

sudo service network-manager restart

I have the same problem, but I can't start network. ifconfig shows only the device lo. So I start the PC with CD in live mode. I mount the disk with the installed system (/dev/sdax) Then I open a terminal and do the follow:

mkdir sdax 
sudo mount /dev/sdax sdax
sudo mount -o bind /dev /home/ubuntu-user/sdax/dev
sudo mount -o bind /proc /home/ubuntu-user/sdax/proc
sudo mount -o bind /sys /home/ubuntu-user/sdax/sys
sudo chroot /home/ubuntu-user/sdax
echo "nameserver" > /etc/resolv.conf
apt-get update
apt-get upgrade
umount /dev/sdax

The "x" is the partittionnumber from the installed system

Then I reboot the system and it works.

Not the answer you're looking for? Browse other questions tagged or ask your own question.