2

This question already has an answer here:

I tried to install Ubuntu 16.04 on another computer running Ubuntu 14.04 from a bootable USB stick. During the installation I chose not to delete the existing files, but only to remove Ubuntu 14.04 and install Ubuntu 16.04. I got a warning message telling me to create a partition with at least 1 Mb and a specific name (which now I don't rembember). Quite stupidly, I ignored that message and continued the installation. The installation was succesfully completed, but now I can boot from neither the USB stick nor the hard drive.

If I try to boot without the USB stick, I get

error: file not found
grub rescue>

I tried to follow this page and I have the following situation.

grub rescue> ls
(hd0) (hd0,gpt5) (hd0,gpt4) (hd0,gpt3) (hd0,gpt2) (hd0,gpt1) (hd1)

I set

grub rescue> set prefix=(hd0,gpt3)/boot/grub
grub rescue> set root=hd0,gpt3

because only with this choice I get a meaningful answer to

grub rescue> ls /

(in all other cases I get "error: unknown filesystem"). If I now type "insmod normal" I get

grub rescue> insmod normal
error: file not found.

Here I am stuck and don't know what to do. Note that I also tried to run insmod normal on all other partitions (as suggested here), but without success.

If I try to boot from the USB stick, I get a screen of incomprehensible messages, and I can't do anything. The last two are

[ 1.074641] Kernel Offset: disabled
[ 1.074664] ---[ end Kernel panic - not syncing: VFS: Unable to mount root fs in unknown-block(0,0)

Any help would be appreciated. PS: I don't care if I lose any data, I just want my computer to work again.

marked as duplicate by David Foerster, karel, Eric Carvalho, Community Mar 27 '17 at 14:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

Easiest and hassle free solution is to install ubuntu again and do a wipe, since you said you not necessarily need to access data on this machine.

  • Yes, but how? I can't boot from the USB stick. – Davide Cesare Veniani May 14 '16 at 13:17
  • Have you any machine you can recreate the stick on? sound like you forgot to create the EFI partition for ubuntu. – Videonauth May 14 '16 at 13:19
  • What do you mean, recreate? Should I format the USB stick, make it bootable and try again? – Davide Cesare Veniani May 14 '16 at 13:19
  • Exact this is what I'm asking. – Videonauth May 14 '16 at 13:20
  • Yes, I can. I'll do it, but I don't think I've made any changes to the USB stick after I used it to install Ubuntu 16.04. :/ – Davide Cesare Veniani May 14 '16 at 13:22
0

Thanks to the help of a user that has now deleted his answer, I could find a solution: my USB stick was somehow corrupted, so I recreated the bootable USB stick and reinstalled Ubuntu 16.04 (this time making a complete wipe).

After I recreated the USB stick, I didn't get the kernel panic error message (see also this answer).

  • 1
    Well then i can undelete my answer. i deleted it because i thought it was of no use. – Videonauth May 14 '16 at 14:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.