0

I'm trying to access the sdcard that is inserted in my HP Officejet Pro 8500A.

My research shows that it should be accessible via

The IP and the folder memory_card. For instance if the printer's ip is: 192.168.1.33:

For Windows:

\\192.168.1.33\memory_card

For Unix:

smb://192.168.1.33/memory_card

On my Windows machine you can browse or share the folder from the file browser without a username or password prompt. However, on Ubuntu I'm getting a username and password prompt when I try to browse or connect to the resource using Nautilus or any of the other file browsers such as Nemo.

I also tried to mount it with gvfs-mount as what I do with many other shares that has passwords. It still prompts for a username and password, whereas there isn't in this case.

More research shows solutions such as providing "guest/hp" for the "username/password" (https://www-user.tu-chemnitz.de/~klada/?site=projects&id=hpmem).

I tried this command:

$ sudo mount -t cifs //192.168.15.90/memory_card /mnt/ -o username=guest,password=hp

It has the following permission error:

mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I've been trying to search for a cifs option that recognizes there isn't a user name or password to for the share.

From HP Support:
http://h30434.www3.hp.com/t5/Inkjet-Printing/Accessing-SD-Card-over-network-Officejet-Pro-8600/td-p/1259641

  • 1
    The usename and password prompt is optional. There should be and option of connecting as anonymous user, if the share is configured to accept passwordless connections. – mikewhatever May 14 '16 at 12:34
  • @mikewhatever Thanks. I forgot to include the detail that there is an anonymous option nautilus. However, it will not connect to the share. It responses the same way my normal shares respond if I try to connect to one of my regular shares that has passwords, but try to use anonymous to connect. – L. D. James May 14 '16 at 12:45
  • @Videonauth The user, as in this case, don't have access to modify Windows. Look at details of the previous comment. – L. D. James Nov 4 '17 at 14:18
  • Retracted my CV – Videonauth Nov 4 '17 at 14:21
0

The option sec=ntlm needs to be specified. The sec specifies the security modem. ntlm used to be the default mode and didn't need specification.

You can mount the (the HP printer sdcard) device with:

$ sudo mount -t cifs //192.168.15.90/memory_card /mnt/ -o sec=ntlm

This will provide ntlm for password hashing, whereas you won't be prompt for a password to access the mount.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.