11

Kind of an Ubuntu noob here. I'm trying to run 2 external monitors along with my laptop monitor on Ubuntu 11.04. I have a Lenovo T520 with the following graphics:

VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])

I have turned on all three displays under "Monitors", but only the two external screens are displaying anything. The laptop screen will not display.

Running xrandr gives the following (when both externals are hooked up):

Screen 0: minimum 320 x 200, current 3600 x 1080, maximum 8192 x 8192

LVDS1 connected (normal left inverted right x axis y axis) 1600x900 60.0 + 50.0
1440x900 59.9
1360x768 59.8 60.0
1152x864 60.0
1024x768 60.0
800x600 60.3 56.2
640x480 59.9

VGA1 connected 1680x1050+1920+0 (normal left inverted right x axis y axis) 473mm x 296mm 1680x1050 60.0*+ 1600x1200 60.0
1280x1024 75.0 60.0
1440x900 75.0 59.9
1280x960 60.0
1152x864 75.0
1280x720 60.0
1024x768 75.1 70.1 60.0
832x624 74.6
800x600 72.2 75.0 60.3 56.2
640x480 72.8 75.0 66.7 60.0
720x400 70.1

HDMI1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 531mm x 298mm 1920x1080 60.0*+ 1600x1200 60.0
1680x1050 60.0
1280x1024 75.0 60.0
1440x900 75.0 59.9
1152x864 75.0
1280x720 60.0
1024x768 75.1 70.1 60.0
800x600 72.2 75.0 60.3 56.2
720x480 59.9
640x480 72.8 75.0 60.0
720x400 70.1

DP1 disconnected (normal left inverted right x axis y axis)

HDMI2 disconnected (normal left inverted right x axis y axis)

HDMI3 disconnected (normal left inverted right x axis y axis)

DP2 disconnected (normal left inverted right x axis y axis)

DP3 disconnected (normal left inverted right x axis y axis)

As you can see, the LVDS1 display is "connected" but no resolution is selected, even though a resolution is selected under the "Monitors" window. Am I doing something wrong? Or is this even possible? Sorry if this is a stupid question.

  • It's not typical for an integrated graphics chip to be able to support three monitors. My hunch is that your chipset just isn't powerful enough. But i could be wrong. – user32085 Nov 8 '11 at 19:05
  • 1
    Have you tried ARandR? It's a graphical interface for RandR. I have a Lenovo SL400 and once I did that test (LVDS1, VGA and HDMI) and all of them worked nice. – Nicolás Nov 10 '11 at 1:55
  • 2
    @Nicolás: Just tried ARandR. Nice tool with easy interface. However, after I created my screen layout, activated the three displays and pressed the commit (Green Check mark) button, this error was thrown: "XRandR failed: XRandR returned error code 1: xrandr: cannot find crtc for output LVDS1." I did some googling of this error, but couldn't come up with much – pmoseph Nov 10 '11 at 15:49
  • 1
    Had exactly the same problem - how did you get this to work? – Bradley Jul 28 '13 at 1:00
  • 1
    I had been using 3 monitors, internal, vga and hdmi->dvi adaptor on an HP EliteBook. This worked in Debian 7/Fluxbox, though required Arandr and timing seemed important. ie, when starting X, I had to keep the HDMI connected one unplugged, the plug it in and restore my Arandr config. After sleeping, it required some unplugging and plugging to get it going again. In Ubuntu 13.10, I get no such luck, it will only do 2 at a time with the same error as the OP – ljs.dev Nov 7 '13 at 19:10
1

I have tried same thing with my HP dv9087ea but can not get all three monitors run in same time. I think laptops can not do that.

  • 3
    I'm having the same problem here, but I can easily work with 3 displays in Windows, so it is not a issue of the laptop. – RSFalcon7 Apr 5 '14 at 16:27
1

From the information you posted, you only have Intel Integrated Graphics: You can totally ignore people saying anything about NVidia. While not 100% accurate, 2nd generation means Sandy Bridge. That generation of CPUs only supported 2 monitors. You can verify that, but for that it would be useful to have the exact model of your CPU.

However, I know my i7-2630QM is a Sandy Bridge CPU ( https://en.wikipedia.org/wiki/Sandy_Bridge ). If you look it up at ark.intel.com, you get this. Under the section "Graphics Specifications", you'll find "# of Displays Supported ‡", which says 2. I'd suggest you try the same for your CPU.

You have to go over the CPU information. The reason for this is that Intels descriptions of integrated graphics are always very vague. Some CPUs might have features in their GPU that others don't (eg Celeron vs i7). The only way is to look up on Intels website.

0

I have a very similar xrandr listing on my Latitude e3660, and tried much the same thing using the 12.04 normal display configuration thingy - no dice.

Activating the laptop screen LVDS1 and committing just gave me a weird dialogue box that repeatedly tried to draw itself while it gradually drifted down the screen, and never filled in the body of the window - just showed the background through. It stayed around after I cancelled the display configuration thingy (without saving the change) until it escaped off the bottom of the screen and I restarted my login session to make sure it didn't get anywhere interesting - should probably report it as a bug.

With a feeling it was a limitation of available video memory and/or trying to have a display that's too wide for the chipset, I tried stacking the screens on top of each other, reducing their resolution to fit into the original two large screen footprint, but... nope.

0

I just stumbled over this while googling something. It is possible to run it with three monitors, but without any 3d acceleration, because nvidia and intel use differen glx versions, which both install in the same place. I wrote something about at: https://bbs.archlinux.org/viewtopic.php?id=125207

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.