4

I am using kubuntu 16.04 on this PC .

The problem that I am facing is:

Wifi issue: It doesn't discover wifi at times and keeps getting disconnected randomly. Also, when I am connected to a WiFi works very slow. But things go smooth when I boot into windows. Information about wireless card:

abhishek@hp:~$ sudo lshw | grep wireless
                   description: Bluetooth wireless interface
                capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
                configuration: broadcast=yes driver=rtl8723be driverversion=4.4.0-22-generic firmware=N/A ip=192.168.1.13 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn

Information about hardware:

$ lspci |grep Network
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter

abhishek@hp:~$ cat /etc/modprobe.d/rtl8723be.conf
options rtl8723be fwlps=N ips=N

dmesg output related to issue:

[ 4288.272924] pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e5(Receiver ID)
[ 4288.272935] pcieport 0000:00:1c.5:   device [8086:9d15] error status/mask=00000001/00000000
[ 4288.272943] pcieport 0000:00:1c.5:    [ 0] Receiver Error         (First)
[ 4297.800384] ------------[ cut here ]------------
[ 4297.800424] WARNING: CPU: 3 PID: 1355 at /build/linux-UbQGH5/linux-4.4.0/ubuntu/i915/intel_uncore.c:649 __unclaimed_reg_debug+0x80/0x90 [i915_bpo]()
[ 4297.800427] Unclaimed register detected after reading register 0x65f10
[ 4297.800428] Modules linked in: nvram msr cmac rfcomm drbg ansi_cprng ctr ccm bbswitch(OE) bnep nls_iso8859_1 nvidia_uvm(POE) arc4 rtl8723be(OE) btcoexist(OE) rtl_pci(OE) rtlwifi(OE) uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_core v4l2_common videodev media mac80211 intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp kvm snd_hda_codec_hdmi snd_hda_codec_realtek cfg80211 snd_hda_codec_generic snd_soc_skl snd_soc_skl_ipc snd_hda_ext_core snd_soc_sst_ipc snd_soc_sst_dsp snd_soc_core hp_wmi sparse_keymap rtsx_pci_ms memstick snd_compress ac97_bus btusb snd_pcm_dmaengine btrtl dw_dmac_core btbcm snd_hda_intel btintel snd_hda_codec bluetooth irqbypass crct10dif_pclmul crc32_pclmul aesni_intel snd_hda_core snd_hwdep snd_pcm aes_x86_64 lrw gf128mul glue_helper ablk_helper cryptd
[ 4297.800463]  joydev input_leds serio_raw wmi hp_accel lis3lv02d snd_seq_midi snd_seq_midi_event input_polldev hp_wireless snd_rawmidi snd_seq snd_seq_device snd_timer snd mei_me mei soundcore shpchp tpm_crb int3403_thermal processor_thermal_device int340x_thermal_zone intel_soc_dts_iosf int3400_thermal acpi_thermal_rel acpi_pad mac_hid parport_pc ppdev lp parport autofs4 hid_generic usbhid hid rtsx_pci_sdmmc nvidia_drm(POE) i915_bpo nvidia_modeset(POE) nvidia(POE) intel_ips i2c_algo_bit drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sys_fops psmouse r8169 rtsx_pci mii drm ahci libahci video fjes
[ 4297.800491] CPU: 3 PID: 1355 Comm: alsa-sink-ALC32 Tainted: P           OE   4.4.0-22-generic #39-Ubuntu
[ 4297.800492] Hardware name: HP HP Pavilion Notebook/80A4, BIOS F.78 03/07/2016
[ 4297.800494]  0000000000000086 00000000b30b4625 ffff880276dd7780 ffffffff813e9c53
[ 4297.800496]  ffff880276dd77c8 ffffffffc0cea888 ffff880276dd77b8 ffffffff81080fb2
[ 4297.800498]  0000000000000000 0000000000000001 0000000000065f10 ffff88026f890080
[ 4297.800500] Call Trace:
[ 4297.800506]  [<ffffffff813e9c53>] dump_stack+0x63/0x90
[ 4297.800509]  [<ffffffff81080fb2>] warn_slowpath_common+0x82/0xc0
[ 4297.800511]  [<ffffffff8108104c>] warn_slowpath_fmt+0x5c/0x80
[ 4297.800515]  [<ffffffff816f7588>] ? pci_conf1_write+0xb8/0xf0
[ 4297.800534]  [<ffffffffc0c5aac0>] __unclaimed_reg_debug+0x80/0x90 [i915_bpo]
[ 4297.800550]  [<ffffffffc0c609ae>] gen9_read32+0x35e/0x390 [i915_bpo]
[ 4297.800567]  [<ffffffffc0c66bb9>] i915_audio_component_codec_wake_override+0x39/0xb0 [i915_bpo]
[ 4297.800573]  [<ffffffffc0e839cf>] snd_hdac_set_codec_wakeup+0x3f/0xa0 [snd_hda_core]
[ 4297.800575]  [<ffffffffc0e970c7>] azx_runtime_resume+0x187/0x1b0 [snd_hda_intel]
[ 4297.800579]  [<ffffffff8143987b>] pci_pm_runtime_resume+0x7b/0xa0
[ 4297.800581]  [<ffffffff81556b23>] __rpm_callback+0x33/0x70
[ 4297.800584]  [<ffffffff81439800>] ? pci_restore_standard_config+0x40/0x40
[ 4297.800586]  [<ffffffff81556b84>] rpm_callback+0x24/0x80
[ 4297.800588]  [<ffffffff81439800>] ? pci_restore_standard_config+

When I have tried so far:

sudo add-apt-repository ppa:hanipouspilot/rtlwifi   
sudo apt-get update    
sudo apt-get install rtlwifi-new-dkms linux-firmware

The first solution from here. Didn't try the second one because I will have to recompile with each kernel update then.

I tried make install from this https://github.com/lwfinger/rtlwifi_new but it doesn't work either.

10
  • Hi, could you check if this file exists; /etc/modprobe.d/rtl8723be.conf ?
    – ankit7540
    May 21, 2016 at 3:58
  • @ankit7540 abhishek@hp:~$ ls /etc/modprobe.d/rtl8723be.conf /etc/modprobe.d/rtl8723be.conf abhishek@hp:~$ cat /etc/modprobe.d/rtl8723be.conf options rtl8723be fwlps=N ips=N May 21, 2016 at 4:03
  • try this; echo "options rtl8723be fwlps=0 ips=0 ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be.conf This makes changes to the file mentioned for network adapter (power settings and antenna selection). After this change, reboot and check wifi connection.
    – ankit7540
    May 21, 2016 at 4:06
  • @ankit7540 Now, it can discover the wifi-networks. And internet connection worked for some time after rebooting and then again stopped working. May 21, 2016 at 4:16
  • @ Abhishek Bhatia - Check with echo "options rtl8723be fwlps=0 ips=0 ant_sel=1" | sudo tee /etc/modprobe.d/rtl8723be.conf for selecting the antenna 1 and try. You have to reboot again.
    – ankit7540
    May 21, 2016 at 4:19

2 Answers 2

3
+25

This issue is an ongoing problem and the following is more like a temporary answer.

Step 1. Add repository for the latest driver (maintained by lwfinger on GitHub) and install it.

sudo add-apt-repository ppa:hanipouspilot/rtlwifi sudo apt-get update sudo apt-get install rtlwifi-new-dkms linux-firmware

If you cannot install the driver then, disable secure boot from BIOS ( some notebooks have had this issue).

Your wifi-adapter should be working now (though maybe having weak signal or disconnects after some time).

Step 2. Edit the configuration file for the new driver for specific antenna selection and power management,

--First make a backup.

sudo cp /etc/modprobe.d/rtl8723be.conf /etc/modprobe.d/rtl8723be.old.conf

then,

echo "options rtl8723be fwlps=0 ips=0 ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be.conf

Step 3. reboot

Your wifi-adapter should be working better now. It is suggested to test wireless connection under load for some time. User may test with ant_sel=1 or removing this parameter to ascertain best working condition. With every change reboot is needed.

More information: With future kernel update, no additional configuration is needed since linux-firmware is also installed.

Referring solutions : Another issue with rtl8723be

Driver development by lwfinger on GitHub: rtl8723be driver Follow this for future updates.

1
  • If I turn off the wifi and turn it back on. It doesn't work, i.e. it can't detect any the wifis nearby. Only a reboot fixes it back. Any ideas on this one? Feb 21, 2017 at 18:12
0

I've been searching for a solution for hours now always finding one that suggests installing the driver from https://github.com/lwfinger/rtlwifi_new/ which no longer exists.

Turns out you no longer need that driver as it is part of the kernel now. But you might run into a terrible signal strength issue I was experiencing myself on my laptop.

The only thing that needed to be done was to execute this in a terminal:

sudo tee /etc/modprobe.d/rtl8723be.conf <<< "options rtl8723be ant_sel=1"

As suggested here. Hope this helps someone running into the same problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .