6

So I had Kubuntu 16.04 which had been upgraded from 15.10. Always worked fine and slept when I closed the lid. I installed Ubuntu (switched from Kubuntu) (clean install, formatted root partition) 16.04 and now my laptop won't sleep when I close the lid or when I select Suspend from the power menu.

I tried echo mem > /sys/power/state as root but it only shuts off my screen, everything else stays on, and I can't get the screen to come back on.

I have an HP DV7 Laptop with i7, dual switchable graphics (Intel/AMD Radeon HD 7960M XT). I installed Ubuntu with no third-party drivers, just stock from USB. Also to note that booting into a live session from the USB still doesn't allow suspend.

My system has 2 hard drives laid out like so:

SDA (GRUB boot loader here) Windows 10    
SDB1 (NTFS) Storage drive for both OS'es    
SDB3 /home (ext4)    
SDB5 swap    
SDB6 / (root, ext4)

Windows 10 still works fine. Boots into Ubuntu fine, everything works except suspend.

UPDATE : I'm still at a loss here. I updated my kernel to 4.4.8 but this didn't fix it.

I removed the # from HandleLidSwitch=suspend in the logind.conf and that didn't work.

I ran acpi_listen in the terminal, closed and opened the lid, and it is detecting lid closed and lid opened.

Here is the output of acpi_listen:

button/lid LID close
button/lid LID open

Still not sure why it's not working...

5

I figured it out so I'm posting an answer for those who are stuck like me.

Since pm-suspend worked perfectly for me, I edited this file:

/etc/default/acpi-support

Looked for this line:

SUSPEND_METHODS="dbus-pm dbus-hal pm-utils"

Changed it to this:

SUSPEND_METHODS="pm-utils"

Now it works like it should!

1

This could solve your problem. I once had this problem and i solved it using this method:

Open a terminal: Ctrl + Alt + t

Open logind.conf by running command

sudo vim /etc/systemd/logind.conf

and remove the # before HandleLidSwitch=suspend. You can also change the option suspend to hibernate or poweroff

Fix from Launchpad Bug #863834, comment #30:

  1. Open a terminal: Ctrl + Alt + t
  2. sudo mkdir /etc/acpi/local
  3. sudo vim /etc/acpi/local/lid.sh.post
  4. Copy this short script:

     #!/bin/bash
     if grep -q closed /proc/acpi/button/lid/*/state
     then
         /usr/sbin/pm-suspend
     fi
    

    ... and paste it into vim by typing: "+p

  5. Save by typing ZZ (in capitals)
  6. sudo chmod 755 /etc/acpi/local/lid.sh.post (so it works even when power management is handled under the logged-in user instead of root)

Hope it solves your problem.

1
  • No this doesn't work. But, if I do "sudo pm-suspend", the laptop does go to sleep, and wakes up fine. But closing the lid still does nothing. – Delorean May 17 '16 at 19:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.