20

I am trying to change the default Audio sound system to ALSA so it fixes some sound issues. How can this be done?

Am using 1.3.x branch from PPA which is much better than the 1.1.x and 1.2.x in every way.

  • not sure I understand you - what setting have you got in the audio tab of winecfg? – fossfreedom Nov 8 '11 at 18:26
  • By default wine uses winepulse. There is no setting to change that. The only settings there are to change the audio card. – Luis Alvarado Nov 8 '11 at 18:47
20

I am aware that wine has just undergone a complete rewrite of the audio system and maybe winetricks could still help with your question...

In a terminal run

winetricks

enter image description here

enter image description here

enter image description here

  • 1
    Yes it works and it works better for going back to another sound than the one I was going to mention. – Luis Alvarado Nov 8 '11 at 21:06
  • very interesting! I thought we were stuck with pulseaudio, so many options there, never saw it, gonna read them all, thx! – Aquarius Power Feb 24 '15 at 19:31
  • 1
    Command-line alternative: winetricks sound=alsa (execute this in your terminal). – VasyaNovikov Dec 5 '15 at 22:39
  • One problem: there are no sound= entries in the list for me! Fedora 29, I have wine-alsa and wine-pulseaudio packages both installed. Running in a 32-bit prefix. – Josh Hansen Jan 25 at 21:37
4

In your terminal type winetricks sound=alsa.

This does the same effect as in @fossfreedom-s solution. Note: if you want to disable all audio in wine, use winetricks sound=disabled.

3
  1. Open a terminal and run regedit.
  2. Go to HKEY_CURRENT_USER\Software\Wine\Drivers
  3. Set Audio to alsa

To restore Ubuntu's default value, repeat the first 2 steps and then set Audio to pulse.

  • Setting 'Audio' to 'alsa' or to 'oss' is very necessary for real-time applications, such as games and professional audio, because of the potential of minimum latency (delay) of transfer of sound, from audio processes to audio speakers. – Ioannis Iliadis-Ilousis Jan 4 '15 at 14:15
1

Another way is running gstreamer-properties and selecting ALSA, OSS or PulseAudio in the Default Output and Default Input options. Whichever option the user prefers. Works like the winetricks mentioned by fossfreedom but this is only for sound in general. In his case you can do a lot more.

1

that can be done via winetricks also:

winetricks settings sound=alsa

to see all available options:

winetricks settings list | grep sound
0

All you need to do is enable Alsa and disable all others in winecfg. You can also try padsp wine insert-application-name-here, this will redirect it to OSS, but fixes many problems with sound.

If you do not see the option there, you may be able to add it to your .reg file (You may need to look at the WINE Wiki to find out how to do this).

  • There is no setting in 1.3.25+ to change that. – Luis Alvarado Nov 8 '11 at 18:48
  • @LuisAlvarado I haven't used WineCfg in a little while, but can you post a screenshot? – RolandiXor Nov 8 '11 at 18:52
  • Ok this is awkward. I was going to put a screenshot of the audio tab of the winecfg but I did something before. Since I was looking for someway to manage the audio I found that gstreamer-properties can change the default audio system manager. After just changing it to Alsa wine is not using winealsa.drv forever and it solved several issues with it. But now I can not go back to pulseaudio for wine. I will put it as an answer if I give up trying to send it back to winepulse. – Luis Alvarado Nov 8 '11 at 19:42
  • @LuisAlvarado I'm confused... but okay. – RolandiXor Nov 8 '11 at 19:47
0

I agree with FossFreedom, however I would add that you may also need to un-install Wine and delete the .wine folder, and then re-install a fresh copy of Wine, should your Windows application are not working properly.

This time configuring Winetricks as described BEFORE installing any Windows application.

Worked for me.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.