2

On my client PC I'm running Windows 10 and I have installed XMing and Xming Fonts.

I am running Putty and I have configured it to enable X11 Forwarding. I have tried leaving the X display location blank (as default) and also with the value :0.0.

On my server I'm running Ubuntu on AWS. I edited the /etc/ssh/ssh_config file to include the following two lines:

ForwardX11 yes
ForwardX11Trusted yes

I also installed xauth using sudo apt-get install xauth

Whenever I try to run an application, like xterm & or xclock I get the same error:

PuTTY X11 proxy: Unsupported authorisation protocol
Error: Can't open display: localhost:10.0

I've combed the Internet and found a number of other people reporting the same problem, but no clear fix, at least that has worked for me. Anybody else solved this problem?

  • try adding 127.0.0.1 localhost to your hosts file – user257256 May 14 '16 at 5:26
2

I was able to finally figure out a solution. The problem seems to have been with the .Xauthority file. The owner of the file was root (see below).

-rw-------  1 root   root      124 May 13 18:19 .Xauthority
-rw-------  2 ubuntu ubuntu      0 May 14 19:56 .Xauthority-c
-rw-------  2 ubuntu ubuntu      0 May 14 19:56 .Xauthority-l

I tried to delete the file and restart xauth and ssh but that didn't work so I removed xauth entirely using sudo apt-get purge xauth. Then I deleted all of the .Xauthority files in my home directory. Then I reinstalled xauth, again using sudo apt-get install xauth. The new .Xauthority file was owned by ubuntu.

-rw-------  1 ubuntu ubuntu    100 May 14 20:27 .Xauthority

I ended up testing Putty with the X display location of :localhost.0 as well as :0.0 but it didn't seem to matter since both worked. I then tested with xclock & and it popped right up, finally.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.