1

I am running Ubuntu 14.04 with a terminal window. Because I type fairly quickly I sometimes use ctrl-u to wipe out my partially entered line which works great. Once my partially typed line is wiped out, I am back at my command prompt and am ready to enter a command.

But sometimes I accidently press ctrl-shift-u and then immediately start typing (thinking I am at the command prompt again). Instead of wiping out the line, the characters I type are underlined and sometimes get converted into hex characters, or sometimes if I type too many characters when it is in this mode, my keyboard completely locks up. Even if I open an new terminal window I still can't type. The only solution is a reboot.

What am I activating when I type ctrl-shift-u followed by other characters? And is there a way for me to configure this feature off so I don't lock myself up?

(Perhaps I should type more carefully so I don't accidently hit ctrl-shift)

Thanks for your help, Robert

1
  • I don't know why it is slowing your system, but you are activating unicode input. – user448115 May 13 '16 at 18:48
1

I just found out that IBus was activating, and it substitutes Unicode characters. I guess pressing more than 4 characters locks up keyboard input.

I found out how to disable IBus completely. I went to the Ubuntu system settings, selected Language Support. Under Keyboard input method system I changed IBus to none, and my ctrl-Shift-U lockup problems are now gone.

Thank you Adonis for directing me to the solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.