I have a new HP Pavilion Gaming Notebook and a new installation of Ubuntu 16.04. When I press Ctrl + Alt + F1 I go start seeing the errors shown in the following image and it doesn't allow me to interact with the console:

enter image description here

I also see these errors for a while everytime I boot. I need to do Ctrl + Alt + F1 to access a non graphical terminal to install some Nvidia drivers. What's going on?

What's causing the problem seems to be: 00:1c.5 PCI bridge [0604]: Intel Corporation Sunrise Point-H PCI Express Root Port #6 [8086:a115] (rev f1)

jpiabrantes@joao:~$ lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation Sky Lake Host Bridge/DRAM Registers [8086:1910] (rev 07)
00:01.0 PCI bridge [0604]: Intel Corporation Sky Lake PCIe Controller (x16) [8086:1901] (rev 07)
00:02.0 VGA compatible controller [0300]: Intel Corporation Skylake Integrated Graphics [8086:191b] (rev 06)
00:04.0 Signal processing controller [1180]: Intel Corporation Skylake Processor Thermal Subsystem [8086:1903] (rev 07)
00:14.0 USB controller [0c03]: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller [8086:a12f] (rev 31)
00:14.2 Signal processing controller [1180]: Intel Corporation Sunrise Point-H Thermal subsystem [8086:a131] (rev 31)
00:16.0 Communication controller [0780]: Intel Corporation Sunrise Point-H CSME HECI #1 [8086:a13a] (rev 31)
00:17.0 SATA controller [0106]: Intel Corporation Sunrise Point-H SATA Controller [AHCI mode] [8086:a103] (rev 31)
00:1c.0 PCI bridge [0604]: Intel Corporation Sunrise Point-H PCI Express Root Port #5 [8086:a114] (rev f1)
00:1c.5 PCI bridge [0604]: Intel Corporation Sunrise Point-H PCI Express Root Port #6 [8086:a115] (rev f1)
00:1c.6 PCI bridge [0604]: Intel Corporation Sunrise Point-H PCI Express Root Port #7 [8086:a116] (rev f1)
00:1f.0 ISA bridge [0601]: Intel Corporation Sunrise Point-H LPC Controller [8086:a14e] (rev 31)
00:1f.2 Memory controller [0580]: Intel Corporation Sunrise Point-H PMC [8086:a121] (rev 31)
00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-H HD Audio [8086:a170] (rev 31)
00:1f.4 SMBus [0c05]: Intel Corporation Sunrise Point-H SMBus [8086:a123] (rev 31)
01:00.0 3D controller [0302]: NVIDIA Corporation GM107M [GeForce GTX 950M] [10de:139a] (rev a2)
07:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader [10ec:522a] (rev 01)
08:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 0a)
  • 1
    Could you post the output of : ` lspci -nn ` . Thanks – ankit7540 May 13 '16 at 16:22
  • @ankit7540 I've updated my question with that info – João Abrantes May 13 '16 at 17:25
  • Hey been a long time, same issue with same notebook did you solved it now? – Vinz243 Aug 8 '16 at 15:10
  • Yes @Vinz243 the answer bellow solved my problem after all! – João Abrantes Jan 22 '17 at 12:51
  • I'm getting this also on Ubuntu 18.04, so this is the bug that keeps giving. – Kingsley Oct 14 at 21:21
up vote 58 down vote accepted

Try this,

Use this link ( about the adding paramter to kernel here) to understand about adding kernel boot paramter temporarily and making it permanent. Then,

Add the parameter , pci=nomsi

And reboot.

If the problem is solved then make the change permanent. If does not work then try,

pci=noaer

same way and make it permanent if this works.

(*Reason for appearance is related to the recent Intel Skylake architecture CPUs and Realtek rtl8723be wireless adaptor.

The ubuntu team knows about it. Read more here Bug_track_ubuntu_PCIe bus error )

  • Did you try this, pci=noaer ? – ankit7540 May 14 '16 at 10:44
  • 2
    I had the same problem. Both your solutions worked. I went with pci=noaer as this is the first one mentioned in the ubuntu team link you posted. Thanks. – user643722 Nov 18 '16 at 9:46
  • to make it permanent, use askubuntu.com/questions/271058/… *note that there are two similar lines to modify – Ferroao Jun 30 '17 at 18:52
  • I'm using an HP Pavilion 15-ab217ng notebook with Ubuntu 16.04. I had these errors for years and they were driving me nuts. pci=noaer worked for me. Thank you so much. – Jenny O'Reilly Dec 6 '17 at 17:47
  • pci=noaer help me on Xubuntu 14.04 – Luis Lasser Feb 8 at 16:18

Here already answers are provided which also helped me a lot. I use text mode of ubuntu 16.04 and so

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi"

didn't helped me. Here what I changed was -- (in /etc/default/grub)

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi"
GRUB_CMDLINE_LINUX="text pci=nomsi"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

which solved my error(NOTE - I used only pci=nomsi, and in case it don't work other option is pci=noaer), that may help solve anyone facing the same error.

protected by Community Aug 20 '17 at 15:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.