I am posting this question from my Windows desktop, because as of this morning my laptop is no longer even an internet accessible device, and doesn't even seem to think it's supposed to be an internet accessible device.

My OS is Ubuntu 14.04, 64 bit. The laptop is an Asus X551CA, and I got it in 2013 April.

Last night, I installed a routine Ubuntu update. I then restarted my computer. This morning, I have no internet. Like, at all. When I open up Firefox, every single tab says it failed to load the requested page. At the top right corner of the screen, there isn't even an internet icon. I tried connecting my ethernet cable, but it didn't even react at all.

I tried restarting like three or four times. It doesn't help. The internet is still missing.

I tried the following terminal commands, as suggested by responders to this question.

sudo service networking restart

sudo service networking force-reload

sudo dhclient

sudo apt-get update

Each one returned errors.

The first one returned­ this.

stop: Job failed while stopping
start: Job is already running: networking

The second one returned this.

reload: Job is not running: networking

The third one returned this.

avahi-daemon stop/waiting

And the fourth one, after spitting out a large wall of text, then returned this.

W: GPG error: http://deb.opera.com stable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 63F7D4AFF6D61D45

I have no idea what to do. It's the very end of the semester, and I have a research project that I need to complete by the end of monday. So it is, to say the least, absolutely imperative that my internet be working soon. Please, please help.

  • I've got the same problem... no idea what to do. – LauriK May 13 '16 at 14:43
  • Can you add the output of rfkill list and lspci -knn | grep Net -A2 – GAD3R May 13 '16 at 15:09
  • Same issue here. – Serge Stroobandt May 13 '16 at 15:33

The issue arose due to a regression introduced with a fix for libnl3 bug #1511735.

I resolved this issue by downloading a newer version of network-manager from another computer with a functional network connection.

Here are the respective download links for the amd64 and i386 architectures.

Copy the .deb file to a USB stick and install it on the affected computer with:

$ sudo dpkg -i network-manager_0.9.8.8-0ubuntu7.3_amd64.deb

For more information, please, refer to:

  • I followed the steps in your second link at the end, and everything is working fine now! Thanks! – Elen Sila May 16 '16 at 16:47

My network was down after my last update as well. I ran update/upgrade from recovery mode and that solved it.

I had to use the root terminal in recovery mode because my recovery mode is buggy. So I had to mount the drive RW manually and bring the network up, ifonfig eth1 up , which I don't think you have to do otherwise.

Be real, be sober.

  • 1
    Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) – David Foerster May 22 '16 at 8:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.