1

I have dual graphic in my laptop AMD radeon 7670M And Intel HD After I installed Ubuntu 16.04 Fan speed is quite high and my laptop lags whenever I view videos on browser or open Facebook Is it due to the AMD drivers no more supported in 16.04 Can I disable AMD and use only Intel

I have dual boot and I use Ubuntu for development stuff so is it possible to use dual graphics in Windows while using only Intel in Ubuntu ?

Is it good to turn off the AMD and will it decrease the noisy fan and the lags I face

1

Yes, you can deactivate the AMD graphics and just use only the intel graphics without problems.

In case you have not already installed it before - install the gksu package from the repositories.

Open a terminal and execute :

sudo apt-get install gksu  

Now execute this command :

gksudo gedit /etc/default/grub  

Add radeon.modeset=0 to this line : GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

so that it reads : GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.modeset=0"

Save the changes you made.

Then execute this command :

sudo update-grub  

Reboot the system and from now on you are using the intel graphics ... and AMD is deactivated.

  • Will there be any problem . can I enable it again . can you please post how to enable it also for future reference – Ezio May 13 '16 at 14:42
  • @Ezio : There will be no problem to re-enable the AMD graphics later - just do the same again, but this time remove radeon.modeset=0 from the line, then update GRUB and reboot the operating system. :) – cl-netbox May 13 '16 at 14:47
  • Thank you for the answer. Will disabling from ubuntu will also disable it from Windows ? – Ezio May 13 '16 at 14:50
  • @Ezio : No, of course not - Windows is a different operating system with completely different drivers. :) – cl-netbox May 13 '16 at 14:51
  • @cl-netbox, I tried the same on my Dell Inspiron 15R 7520 with AMD Radeon HD 7730M. However, instead of Ubuntu, I'm using Debian 8, and the value for GRUB_CMDLINE_LINUX_DEFAULT was "quite". Can you help me? Thanks. – arthursfreire Sep 28 '16 at 18:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.