0

I recenetly installed ubuntu16.04 on my sony vaio VPCEH35en. The brightness control is not working. I have a Nvidia GEforce 410M . I tried to modify the xorg.conf file but ended up with this:

paritosh@Toshu:~$ sudo gedit /usr/share/X11/xorg.conf.d/10-nvidia-brightness.conf
[sudo] password for paritosh: 

** (gedit:6732): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
** (gedit:6732): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-spell-enabled not supported
** (gedit:6732): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-encoding not supported
** (gedit:6732): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-position not supported
2

You can do a tweak in order to control brightness for your laptop. Please follow the following steps:

  1. Open a terminal window.
  2. Type in the following commands then hit Enter:

    sudo apt-get install xbacklight
    
  3. Open the Startup Applications Preferences menu. Click the Add button and add the following information:

    • Name: Brightness
    • Command: xbacklight -set <% number>

Replace <% number> with whatever brightness level you prefer. E.g.: xbacklight -set 50

1

I tried this on my laptop:

sudo apt-get install xbacklight

then

xbacklight -set 80

This set my brightness to 80%. You could find a good value then add the "xbacklight -set xx" code to your startup session commands? That would set a value on logon you liked.

Kind regards, Pete

0

I actually just solved this problem on my own laptop. Open up the terminal and type:

ls /sys/class/backlight

There are several possible options here:

  • If there isn't anything that appears, then that's a driver issue and you need to update and/or install the correct drivers.
  • If there's only one folder, then it is possible to use another method, but, if there are two folders, then what you do is go into the folder that is not nvidia and first check the max_brightness through cat and then mess with brightness through:

    echo [your number here] | sudo tee /sys/class/[FOLDER]/brightness
    

Make sure to not make it is not too close to zero or else it will be hard to see your screen. If your testing is showing effect, then your computer is being affected by that folder. I can't help much more than this, because i'm not too knowledgeable in Linux, still rather new. Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.