15

Went to System Settings -> Sound and nada. Ubuntu Tweak does't appear in the Software Center anymore. How can one disable these dang bongos in 16.04?

1
  • Do you still have this issue? Please accept the answer that was most useful to you so that others with the same issue can find quality answers that work. Thank you! – Elder Geek Jan 11 '17 at 2:04
15

At the login screen use the icon in the upper right to mute the sound. The setting is persistent.

2
  • Hm... seems fragile to me. Prone to mischievous or clumsy people unmuting it. – Ben Leggiero Dec 31 '19 at 18:19
  • 1
    What a nightmare scenario! Thanks for raising this concern. – Organic Marble Dec 31 '19 at 18:31
12

The file that plays when the login screen is shown is:

/usr/share/sounds/ubuntu/stereo/system-ready.ogg

Delete or rename it to prevent the sound from playing altogether, or replace/redirect it to make another sound play instead.

AFAIK this is not unique to 16.04, so this should also apply to all other versions of Ubuntu.

10
  • 8
    Deleting or replacing system files should be discouraged. Those files will be overwritten with every update. There must be a better solution. – Ivan Perez Dec 18 '16 at 2:14
  • 1
    @IvanPerez do you have a source for that knowledge? These are such trivial and old files that I doubt they're included in the update diff. – Ben Leggiero Dec 18 '16 at 7:33
  • 2
    Well, you don't really control what those upgrades will bring. An upgrade that follows all guidelines, passes lintian, and only affects the files it owns, could still undo your changes. And do you consider it a good setup that, if you re-install a package, you "break" things? (By break I mean that a feature no longer works, in this case, the chime being disabled is the feature). (I know my message sounds very direct, but I don't mean it as an attack.) In my case I muted the volume in the log-in screen and the change was permanent and independent from my settings once I log in. – Ivan Perez Dec 20 '16 at 10:17
  • 1
    When it comes right down to it, an update could wipe system files, preferences, user data, et al if it wanted to (or if it's created poorly). I agree this is not an ideal solution, but it is the one I've been using and works reliably for me (and has for many years). If you have a better solution that's guaranteed to be persisted between updates, please write that as your own answer and I'll certainly +1 it! – Ben Leggiero Dec 20 '16 at 20:50
  • 2
    As other solutions suggest, all you need to do is to mute the sound in the login screen. The setting is persistent, and it does not affect sound volume after logging in. This worked for me. – Ivan Perez Dec 27 '16 at 7:34
9

I'm Using Ubuntu 16.10. The answer is surprisingly simple. From the Login screen, mute the sound (the setting is positioned in the top right corner) and that's it. Muting the login screen sound does not affect your session sound. I suggest you also try this for other versions of Ubuntu before installing additional software or tweaks.

1
2

If the audio-icon is not visible at the login screen, try restarting the system. I have a fresh install of Xenial, and the audio controls only show at startup on initial boot, not on subsequent logouts.

1

In both 14.04 and 16.04 /usr/share/sounds/ubuntu/stereo/system-ready.ogg is actually a link to dialog-question.ogg as seen below.

$ ll /usr/share/sounds/ubuntu/stereo/
total 340
drwxr-xr-x 2 root root   4096 Jul 22  2014 ./
drwxr-xr-x 3 root root   4096 Jul 22  2014 ../
-rw-r--r-- 1 root root   5016 Mar  2  2011 bell.ogg
-rw-r--r-- 1 root root   8997 Mar  2  2011 button-pressed.ogg
-rw-r--r-- 1 root root   4035 Mar  2  2011 button-toggle-off.ogg
-rw-r--r-- 1 root root   4035 Mar  2  2011 button-toggle-on.ogg
-rw-r--r-- 1 root root 104421 Mar  2  2011 desktop-login.ogg
-rw-r--r-- 1 root root  26925 Mar  2  2011 desktop-logout.ogg
-rw-r--r-- 1 root root  10660 Mar  2  2011 dialog-error.ogg
-rw-r--r-- 1 root root   5377 Mar  2  2011 dialog-information.ogg
-rw-r--r-- 1 root root   9851 Mar  2  2011 dialog-question.ogg
-rw-r--r-- 1 root root  12217 Mar  2  2011 dialog-warning.ogg
-rw-r--r-- 1 root root  22733 Mar  2  2011 message-new-instant.ogg
-rw-r--r-- 1 root root  10429 Mar  2  2011 message.ogg
-rw-r--r-- 1 root root  29299 Mar  2  2011 phone-incoming-call.ogg
-rw-r--r-- 1 root root   7996 Mar  2  2011 phone-outgoing-busy.ogg
-rw-r--r-- 1 root root   4792 Mar  2  2011 phone-outgoing-calling.ogg
-rw-r--r-- 1 root root  17274 Mar  2  2011 service-login.ogg
-rw-r--r-- 1 root root  14573 Mar  2  2011 service-logout.ogg
lrwxrwxrwx 1 root root     19 Feb 26  2016 system-ready.ogg -> dialog-question.ogg
-rw-r--r-- 1 root root   6994 Mar  2  2011 window-slide.ogg

This being the case modifying the link isn't really modifying a system file, it's modifying a pointer to a system file. It should be simple enough to point it elsewhere to the ogg file of your choice. for instance the slightly more pleasant service-login.ogg with ln -sfT service-login.ogg system-ready.ogg or you could rename or delete the link nullifying it's usefulness but I would prefer to simply repoint it to something I might want to hear.

Sources:

Testing on 14.04 and 16.04 with Unity DE.

https://unix.stackexchange.com/questions/88824/how-can-i-edit-symlinks

http://man7.org/linux/man-pages/man1/ln.1.html

0

I believe the appropriate way to do this would be with a sound theme. You could create a theme that plays a blank or silent .ogg file for this sound. See this answer regarding theme creation.

0

I found that this sound is played due to /usr/share/gdm/autostart/LoginWindow/libcanberra-ready-sound.desktop file, which is provided by gnome-session-canberra package. It says in description that it provides startup/shutdown sounds. Unfortunately, it's not possible to remove this package without breaking ubuntu-desktop package.

There are no knobs or settings to fix this issue.

The least invasive thing I found was to add X-GNOME-Autostart-enabled=false into /usr/share/gdm/autostart/LoginWindow/libcanberra-ready-sound.desktop file.

I'll file some bugs about this (package should be removable without dependencies break, and there should be some normal way to disable sounds through symlinks in /etc or separate settings).

PS Bugs: https://bugs.launchpad.net/ubuntu/+source/libcanberra/+bug/840858 https://bugs.launchpad.net/ubuntu/+source/ubuntu-meta/+bug/1714764

1
  • You might want to note that your answer is gnome specific as the content of the libcanberra-ready-sound.desktop file indicates.. For the modify symlinks solution see my answer – Elder Geek May 7 '18 at 16:43
0

I had disabled the login sound as suggested by Organic Marble, but I would still occasionally get a loud chime when I hit the splash screen. It was an absolute PITA to diagnose because it would only happen sometimes. I eventually worked out that it was happening when I had connected or disconnected my power cable while the laptop was suspended AND if the laptop sound wasn't muted. When the laptop reactivated, it noticed the (dis)connect at the same time the splash screen came on.

I couldn't find a setting anywhere that would disable that chime, so I ended up going with a variant of Ben Leggiero's answer and renaming files:

/usr/share/sounds/KDE-Sys-Log-In-Long.ogg 
/usr/share/sounds/KDE-Sys-Log-In.ogg
/usr/share/sounds/KDE-Sys-Log-In-Short.ogg
/usr/share/sounds/Oxygen-Sys-Log-In-Long.ogg
/usr/share/sounds/Oxygen-Sys-Log-In.ogg
/usr/share/sounds/Oxygen-Sys-Log-In-Short.ogg
0

Create a backup of the sound, delete it and replace it with an empty file

cd /usr/share/sounds/ubuntu/stereo/
sudo cp system-ready.ogg system-ready.ogg.back && sudo rm system-ready.ogg

To turn it back on

cd /usr/share/sounds/ubuntu/stereo/
sudo cp system-ready.ogg.back system-ready.ogg && sudo rm system-ready.ogg.back

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.