0

I've been struggling with this problem for quite a time. I just upgraded my xubuntu to 16.04 and my nvidia drivers broke again. So, as usual, I had to uninstall all nvidia drivers (I was using nvidia-352-updates) along with bumblebee. So I did it, and then I did the same process again (little observation here: I'm using now nvidia-361-updates):

sudo apt-get install nvidia-361-updates -y && sudo apt-get install bumblebee

Ok, everything set up and I headed up to the /etc/bumblebee/bumblebee.conf to point LD_LIBRARY_PATH and the XorgModulePath entry to the correct nvidia folder, that in my case is nvidia-361. After that I just restarted the computer and tried to run:

optirun glxinfo

And I received the answer:

[ranu@ranu-laptop ~]$ optirun glxinfo [ 515.027004] [ERROR]Cannot access secondary GPU, secondary X is not active. [ 515.027105] [ERROR]Aborting because fallback start is disabled.

I was astonished, then I ran a more verbose one (optirun -vv -debug glxinfo):

[ 334.856357] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf [ 334.856840] [INFO]Configured driver: nvidia-361 [ 334.857253] [DEBUG]optirun version 3.2.1 starting... [ 334.857290] [DEBUG]Active configuration: [ 334.857298] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf [ 334.857305] [DEBUG] X display: ebug [ 334.857311] [DEBUG] LD_LIBRARY_PATH: [ 334.857319] [DEBUG] Socket path: /var/run/bumblebee.socket [ 334.857326] [DEBUG] Accel/display bridge: auto [ 334.857341] [DEBUG] VGL Compression: proxy [ 334.857380] [DEBUG] VGLrun extra options: [ 334.857400] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus [ 334.870268] [DEBUG]Using auto-detected bridge virtualgl [ 337.882765] [INFO]Response: No, secondary X is not active. [ 337.882803] [ERROR]Cannot access secondary GPU, secondary X is not active. [ 337.882817] [DEBUG]Socket closed. [ 337.882869] [ERROR]Aborting because fallback start is disabled. [ 337.882887] [DEBUG]Killing all remaining processes.

Weird, LD_LIBRARY_PATH is empty even though it's filled with information in /etc/bumblebee/bumblebee.conf. So I then ran:

bumblebeed -vv -debug

And received the output:

[ 782.329141] [DEBUG]Found card: 01:00.0 (discrete) [ 782.329201] [DEBUG]Found card: 00:02.0 (integrated) [ 782.329236] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf [ 782.329655] [INFO]Configured driver: nvidia-361 [ 782.329684] [DEBUG]Skipping auto-detection, using configured driver 'nvidia-361' [ 782.329850] [DEBUG]successfully loaded bbswitch [ 782.329866] [INFO]Switching method 'bbswitch' is available and will be used. [ 782.329879] [DEBUG]Active configuration: [ 782.329899] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf [ 782.329919] [DEBUG] X display: ebug [ 782.329938] [DEBUG] LD_LIBRARY_PATH: [ 782.329957] [DEBUG] Socket path: /var/run/bumblebee.socket [ 782.329977] [DEBUG] pidfile: /var/run/bumblebeed.pid [ 782.329995] [DEBUG] xorg.conf file: /etc/bumblebee/xorg.conf.DRIVER [ 782.330017] [DEBUG] xorg.conf.d dir: /etc/bumblebee/xorg.conf.d [ 782.330043] [DEBUG] ModulePath: [ 782.330063] [DEBUG] GID name: bumblebee [ 782.330084] [DEBUG] Power method: auto [ 782.330104] [DEBUG] Stop X on exit: 1 [ 782.330123] [DEBUG] Driver: nvidia-361 [ 782.330142] [DEBUG] Driver module: nvidia-361 [ 782.330163] [DEBUG] Card shutdown state: 1 [ 782.330418] [DEBUG]Process /sbin/modprobe started, PID 3094. [ 782.330566] [DEBUG]Hiding stderr for execution of /sbin/modprobe [ 782.333919] [DEBUG]SIGCHILD received, but wait failed with No child processes [ 782.333969] [DEBUG]Configuration test passed. [ 782.334023] [ERROR]Cannot open or write pidfile /var/run/bumblebeed.pid.

Ok, this is even weirder, the configuration test has passed but ModulePath is empty as well and I don't know the why, on top of that it can't write the pidfile, permission issue?

3
  • Ok, don't mind the pidfile problem, I was not running as sudo, so it couldn't write anything and the process (bumblebeed) was already running.
    – ranu
    May 13 '16 at 12:00
  • I noticed that you have set Driver=nvidia-361 in your config file ([bumblebeed] section). Maybe you should try with Driver=nvidia
    – user448115
    May 13 '16 at 12:11
  • You are right about that @adonis! Never thought of it, although another error has appeared.
    – ranu
    May 13 '16 at 12:15
0

It looks like that the Driver entry at the bumblebee config file should be nvidia and not nvidia-361, although the bumblebeed says that the configuration test has passed as seen before:

[ 782.333969] [DEBUG]Configuration test passed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.