When I go to Gparted and try to format my pendrive to exfat,the option is greyed out and I am not able to select it however I can choose other file systems such as ext4,ntfs,etc. Why is that ?


  • 1
    @mikewhatever emmh...not really. Couldn't find anything in that post related to creating exfat
    – Ron
    May 13, 2016 at 8:15
  • IMPORTANT POINT: Make sure to Unmount the disk first. Otherwise the options remain grayed out.
    – Reza Taba
    May 1, 2021 at 22:06

6 Answers 6


Gparted doesn't[UPD 210609] support creation of exfat file systems. You can use mkfs.exfat utility from the terminal like:

sudo mkfs.exfat -n LABEL /dev/sdXn

Replace LABEL with the label that you want for your USB and /dev/sdXn with the partition id of your USB.

You will have to install exfat-utils and exfat-fuse from the universe repository for the above to work;

 sudo apt-get install exfat-utils exfat-fuse 

UPD 210609 is not true anymore, just install exfatprogs

  • 3
    Another alternative to Gparted if you don't want use a terminal is to use Kde Partition Manager. It still support (still) support exFAT. You can my post about it here: askubuntu.com/a/1006553/143133
    – Asme Just
    Feb 15, 2018 at 19:21
  • 3
    If you are using Gnome Disk application and the exFat option is still greyed out, intall exfat-utils and exfat-fuse according to @Ron 's answer. Jan 20, 2020 at 17:30
  • 2020 and still no support in Gparted for exfat lol >< Jun 6, 2020 at 0:48
  • I had to use "Disks" to create a FAT partition, and only then run the mkfs.exfat command above. Aug 17, 2020 at 17:30
  • 1
    @MehrdadSalimi 's comment worked well for me. I installed exfat-utils and exfat-fuse per @Ron 's instructions and then Gnome Disks had the option for exFat ungreyed and I was able to use it.
    – Xandor
    Dec 31, 2020 at 17:09

Workaround: use gnome-disks

This is the default pre-installed disk manager tool on Ubuntu that shows on the Dash as "Disks".

You can also launch if from the terminal with:


Ensure that you have the exfat backend installed:

sudo apt install exfat-utils

Then as of Ubuntu 18.04:

  • Gears button
  • Format Partition
  • Type: "Other"
  • Next
  • exfat

enter image description here

enter image description here

enter image description here

The GUI was a bit different in older versions: GUI tool for formating to exFAT

This is the only non-archaic filesystem I could find that works natively on all of current Mac OS, Windows and Linux, what a world to live in.

  • In case Disks gives error, use Gparted first to format to fat32 for example, and then proceed as above for exFAT. OR, for a stick or other drive with one single partition, use Disk to select the drive in the left panel but then, instead of the gear button, go to the top right button and select "Format disk" and then "No partitioning (empty)", and then do as in the answer.
    – cipricus
    Mar 3, 2020 at 14:09
  • 1
    I don't have the option for exFAT available. Jul 23, 2020 at 20:37
  • 1
    @rvcristiand is it grayed out or doesn't show at all? Which Ubuntu version? Can you check if the exfat-utils package is installed? Jul 23, 2020 at 20:57
  • 1
    It was gray. Buy after install exfat-utils and exfat-fuse it works. Jul 23, 2020 at 21:03
  • @rvcristiand awesome, I thought it was installed by default always, adding to the answer. Jul 23, 2020 at 21:52

I was also getting the same error in gnome-disks. You can switch if you want.

exFat was still greyed. However, I fixed by installing:
sudo apt install exfat-utils exfat-fuse


in Ubuntu 22.04 I was unable to install exfat-utils, but after I installed exfat-fuse and it pulled in a few other exfat items, gparted worked for exfat. So, "sudo apt install exfat-fuse" should work.


While Gparted cannot handle exFAT format, beside other tools that can (Gnome Disks, KDE Partition Manager), there is also the USB Stick Formatter, part of the mintstick tool (which includes both an USB Formatter and an USB Writter), and it covers exFAT format.

enter image description here

It is default in Linux Mint but can be installed in Ubuntu as deb from packages.linuxmint.com or pkgs.org.

  • Please comment why you down-vote and/or vote to delete/close. (Is that even possible for answers?) - If it's because Linux Mint was mentioned, that shouldn't be a reason, as the tool is available for Ubuntu as many other 3rd party apps. - If it's because the answer is not about gparted: all answers here give alternatives to gparted.
    – cipricus
    Mar 4, 2020 at 14:05
  • 1
    Some people downvote without telling who they are and why they do it. I think it is a way to spread bad sentiment, a kind of trolling. Try to ignore it. Most of us appreciate what you and other people do to give advice and share tips.
    – sudodus
    Mar 4, 2020 at 15:01
  • @sudodus - It's even worse — I mean more interesting: this answer was marked for deletion - which is visible to me, but not to many others : Meta: Why do I see a delete option under my answer (and how to find what's that about)?
    – cipricus
    Mar 4, 2020 at 15:04
  • @sudodus - I see you are above 30k reputation, in comments under the meta question it is said that only 20k reputation users can cast deletes for answers. Do you see the delete option? Just curious.
    – cipricus
    Mar 4, 2020 at 15:18
  • No, the delete option only appears if the score is -1 or lower. askubuntu.com/help/privileges/trusted-user
    – Terrance
    Mar 4, 2020 at 15:44

Using Ubuntu Disks app to format my USB stick to exFAT, and I couldn't install neceassary packages, asked GPT-4 and got this, and everything went well afterward:

Install the newer exFAT support packages: In newer versions of Ubuntu (20.04 and later), the exfat-utils and exfat-fuse packages have been replaced by the exfatprogs package. You can install this package by running:

sudo apt install exfatprogs

I installed and exFAT option got ungreyed

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .